Live-Hintergründe

Hallo,
ich habe ein kleines Problem mit OpelLP 2.4. Ich möchte im Hintergrund Live-Videos als Loops laufen zu lassen und über OpenLP normal den Liedtext projizieren. Dafür habe nun eine transparentes Design erstellt. Nun treten zwei Probleme auf:

1. Wenn ich auf "Desktop anzeigen" klicke, wird natürlich erst einmal kein Text gezeigt, aaber wenn ich nun "transparent" einstelle, müsste nun ja, wenn ich "Desktop anzeigen" ausmache, der Liedtext angezeigt werden und im Hintergrund des Desktop, oder? Momentan wird der Text auf schwarzem Hintergrund angezeigt.
2. Wechselt der Text nun nicht wie gewöhnlich, sondern überlappt. Die neue Seite wird einfach auf die andere "geklatscht", sodass man überhaupt nichts mehr lesen kann. 

ist das ein Bug in 2.4. oder habe ich irgendwas falsches eingestellt oder so?

Vielen Dank für eure Hilfe!:)

Comments

  • edited April 2016
    Hallo Eeerik,

    das ghet einfacher als man denkt. ;-)
    Gehe in die Medienverwaltung. Dort musst Du das Video in der Rubrik "Medien" auswählen. Dann startest Du ganz normal die Liedpräsentation und wählst in der Medienverwaltung/Medien die Schaltfläche "Ersetze den Live-Hintergrund" und das gewählte Video wird hinter Deinen Liedtext gelegt und läuft in einer Endlosschleife. Das läuft so lange bis Du das nächste Lied wählst oder bis Du in der Medienverwaltung die Schaltfläche "Setze den Live-Hintergrund zurück" wählst.

    Das gleiche Prinzip kann man auch mit Bildern nutzen. Ich nutze das ab und an um bei bestimmten Liedern einen zum Abendmahl passenden Hintergrund anzuzeigen ohne gleich ein neues Design erstellen zu müssen.

    https://manual.openlp.org/mediamanager.html#media

    Gruß Questions
  • edited April 2016
    Hallo Questions! :)

    Das wusste ich echt noch nicht. Danke dir für die Info! ich habe das direkt mal ausprobiert, allerdings treten hierbei auch Probleme auf. Zum Teil werden die Videos weshalb auch immer gar nicht erst abgespielt, sondern es kommt nur ein schwarzer Hintergrund (Formate der Videos sind alle mp4 und bei anderen klappt es auch o.O). Und wenn ein Video mal läuft, wird dieses nur als "zerstückeltes" angezeigt, sobald ich den Text drüber laufen lassen will. Also bei jeder neuen Folie (Strophe--> Chorus) geht das Video ein "Bild" weiter.:D 

    Ist das bei dir auch so, wenn du das versuchst?


    Lieben Gruß. Erik!


    _____
    Edit:

    Okay, ich habe nun den Mediaplayer auf "WebKit" statt auf "System" umgestellt und nun klappt das auch mit dem fließenden Video samt Text. Jedoch klappt die Loop-Funktion bei mir noch nicht und ich weiß auch noch nicht, wo ich die eventuell einstellen müsste..:O Also momentan läuft das Video so lange, bis es vorbei ist und dann stoppt es (und das Bild/Video-Format verändert sich auch.:( ) und man hat nur noch ein stehendes Bild. Meine Hintergrundvideos sind meistens halt maximal 30 Sekunden lang...
  • Hi Eeerik,

    Also bei mir hat das mit dem Loop problemlos funktioniert. Unter welchem Betriebsystem nutzt Du OpenLP? Ich mach das unter Linux-Mint.

    Hast Du VLC installiert?

    Dass das Ganze manchmal klemmt ist mir auch schon aufgefallen. Ich hab aber noch keine Ahnung wann das passiert. Einmal hatte ich nen Hänger als ich im Video "vorspulen" wollte. Das mag das Backend wohl nicht so gern. Sonst hats bei mir ganz gut geklappt.

    Das mit den einzelnen Bildern hab ich nur in der Vorschau von OpenLP. Auf dem Projektionsausgang läuft das Video prima durch. Vielleicht liegt es an der Auflösung Deiner Videos also an der zu verarbeitenden Datenmenge? Mein Video zum testen ist echt winzig.

    Sonst müsstest Du Dich mal im EN-Forum umhören. Da gibt es evtl. mehr Anwender die das nutzen oder Du versuchst Dich mal im IRC der Entwickler. Die sind sehr Hilfsbereit und wenn Du das Problem eingegrenzt hast kannst Du nen Bug-Report draus machen. Dann wird das bestimmt bei einem der nächsten Updates korrigiert.


    Gruß Questions

  • Hallo Questions,

    ich saß heute Vormittag nochmal dran und da hat es erstaunlicherweise immer mal wieder funktioniert.:) Auch die Loop-Funktion lief auf dem Projektionsausgang (meistens :p) normal.:) Ich teste mal weiter! :)
    Mein Englisch ist leider nicht sooo sonderlich gut.:D Lesen und verstehen klappt, aber solche Dinge in Foren selbst auf englisch zu verfassen, wird bei mir schwierig.:D So ist das Leben! :p 

    Aber danke dir auf jeden Fall für die Tipps! :) 

    Eine Frage allerdings habe ich noch: 
    Im EN-Forum machen das viele, indem sie auf dem Projektor VLC mit einem Video als Loop laufen lassen - soweit klappt das bei mir auch. 
    Und nun erstellen die ein transparentes Theme. Bei denen klappt es wohl, dass man nun dasVideo vom VLC-Player im Hintergrund sieht. 

    Das funktioniert bei mir nicht, denn bei meinem transparenten Theme gehen die Textzeilen übereinander; es erfolgt also kein echter Folienwechsel, sondern nur ein Überlappen der Liedzeilen. Hast du dafür eventuell eine Erklärung? Im EN-Forum habe ich nichts dazu gefunden.

    Und ich nutze Windows 10 und OpenLP 2.4. 

    Lieben Gruß,

    Erik!
  • edited October 2016
    Hi Eeerik, wir spielen mit VLC manchmal ein Video ein und überblenden es dann mit OpenLP mit Hilfe eines transparenten Designs. Das machen wir bei Livehintergründen und wenn wir ein Video mit englischem Ton haben und schnell eine Übersetzung einblenden wollen, ohne das Video neu zu rendern.

    Das Ganze hat auch bis Version 2.2.1. super geklappt. Ab 2.4.x. treten zwei Probleme auf.
    1. Die von dir beschriebene Überblendung des Textes. Wenn man das lange genug macht, ist alles schwarz. Lustig aber nicht hilfreich.
    2. Bei Doppelklick in der Ablaufverwaltung war es sonst so, dass das angeklickte Objekt sofort live geschaltet wird. Wenn man jetzt ein Lied doppelt anklickt, wird es zwar in der Liveansicht auf dem ersten Bildschirm angezeigt, aber beim zweiten Bildschirm/Beamer kommt nichts an. Erst wenn man die zweite Folie des Lied anwählt, wird kurz die erste und dann sofort die zweite Folie angezeigt.
    Da ich keine Zeit habe, die Probleme zu erforschen, sind wir erstmal bei Version 2.2.1. geblieben, auch wenn wir jetzt auf den komfortablen songselect-Zugang verzichten müssen.

  • Hallo,
    gut, dass ich den Post endlich gefunden habe. Ich dachte immer, dass ein Live Hintergrund nicht möglich sei.
    Kann man das Video auch mit dem Song verlinken, sodass das Video automatisch startet?

    Vielen Dank!

    Lukas

Sign In or Register to comment.