VLC subtitle file connection lost when service saved

Version of OpenLP
2_4_3
Operating system
Windows 10
If I add a video to media and happen to have the subtitle file in the same directory then I can play the video from the media manager and the subtitles will display. I can add the item to a service and it will still play the video with subtitles. Once I save the service the subtitles do not play. I assume this is because when I play from the saved service it play the video file from the servicemanager folder not from its original location.

The only workaround I have found is to leave the video out of the saved service and load it into the service at the last minute and run the service from there without saving. This is prone to error because I will often find some other change need for the service and then hit save without thinking and when the video plays later I discover missing subtitles.

Ideally the media item would allow you to add additional files so there is video.mp4 and video.srt in the item with the first one being the one that gets played.

Comments

  • Hi Simon, OpenLP doesn't support subtitles. Your use of subtitles is incidental due to using VLC, but the other video players don't support it.
  • I found a solution which involves encoding the subtitles into the video ahead of time.

    VLC can read SubRip file format and many others. https://en.wikipedia.org/wiki/SubRip. SubRip files are plain text and easy to create but for OpenLP the subtitles needed to be encoded in the video file whichever player you are choosing.

    Lots of sources claim VLC can encode the subtitles in for you. I couldn’t get that to work on OSX or Windows. Instead I used HandBrake from https://handbrake.fr/

    Create subtitles file
    • Create subtitle text file in the same folder as the video with identical name to video and .srt suffix
    • Subtitle format described in wikipedia page above.
    • Check subtitles with VLC (directly not via OpenLP) it will find subtitles file automatically
    With HandBrake encode the subtitles into the video file
    • Select source video file
    • On subtitles tab select subtitles file
    • Select burned in and unselect other subtitle options.
    • There are no controls for font size or colour.
    • Select destination
    • Hit start
    Result a subtitled video ready to presentation.

    If anyone finds a solution which allows the style of the subtitle to be controlled when embedding I would be grateful to here about it.

    Simon
Sign In or Register to comment.