open lp not switching slides with arrow keys

Operating system
Windows 10
having an issue switching slides, images work fine multiple slides do not, i either need to blank the projected image and then play the slide,  or go down to slide 2 then back up, it worked fine untill i upgraded to 2.4, any advice? 


  • When you say "multiple slides" are you talking about songs, Bible verses, or custom slides? Also, what's your Service Item Slide Limits on the Advanced options page?
  • OS: Windows 10
    I'm having the same exact problem and have finally found someone having this issue! When I add images, songs, Bible Verses to a service and try to move down the list with arrow keys, it simply doesn't work. Images in the sequence project onto monitors fine but other slides such as songs, Bible verses, PP slides do not. This also worked fine until I upgraded to 2.4. Please help.

  • Which list? The service or the actual live slide controller? Have you checked your shortcuts?

  • Unfortunately, I have been (and still am) having this very same problem since July 2016 when I upgraded to v2.4.2. I first reported this bug here ( and never did get any relevant assistance or follow-up inquiry from developers (I know they stay busy).

    To my understanding, it has never been addressed (maybe in 2.4.6??), and I have had to learn to just work around it (by 'blanking' and then 'unblanking' the projected image). However, it would really be nice to have a fix.

  • @squidbilly Are you also using Windows? I haven't seen this on either macOS or Linux.
  • @raoul
    Yes, Windows 7 x64. It is present on more than one machine .... all running Windows 7 x64.
  • I have had this issue with my MacBook, but it has always been operator error. When the arrow keys don't work, I find that I have made the wrong window active.
  • @VintageJim
    that's not the case here as the arrow keys (and the openLP window) is indeed active. It even occurs if you are using the mouse to click on the first slide (of the song lyrics or bible text). It's just the first slide ... if you click on 2nd slide or later it displays fine.
  • @squidbilly can you describe to me the exact steps to reproduce this. Please include very specific details, like which mouse button, which list of items you are clicking, etc. Presume I know nothing and don't leave a single action out, no matter how small. If you can include screenshots, that would help a lot. Also please tell me your slide limit setting and your single or double click to go live setting.

    The more information I have the better. Don't presume I know what you're doing.
  • Could this problem be related to the following post?

    I know I did run into display refreshing issues trying to run 2.4 on windows when it came out and ended up going back to version 2.2 (even though we don't use transparent themes). Changing slides wasn't refreshing the display, but blanking/unblanking the display triggered a refresh.

  • In this sample service, I have an image showing the song title followed by the song lyrics as shown in pic1 below:

    I press the right arrow key.

    Notice that the projected display has not been updated. I then press the down arrow key.

    Notice how the projected display now correctly updates to the 2nd verse. Alternatively, if while displaying the image of the song title, I then double left mouse click on the first verse, the result is the same (see below). The live portion is updated to the 1st verse, but not the projected image.

    Again, this behavior was not present until I updated from 2.2 to 2.4 branch. I have attached settings below:

Sign In or Register to comment.