1.9.4 Chinese Bible (CUV) import problem.

edited 12:46PM in Development

Hi

I just install 1.9.4 and imported the Chinese Bible from Biblegateway, and even is has been downloaded successfully, but look like there is encoding problem, i.e. I didn't see the Chinese character, but some random ASCII character.

There is no problem import the all the Chinese Bibles from Sword project, the reason I still going after Biblegateway version is that the Chinese Bible version I want from Sword project include Strong number. so will effect the look in openlp (i.e. have some unwanted space between characters), to fix that I need to remove the strong number tags in the converted output file from Sword project, it would take to long to fix.

So I still wnat to be able to use the Biblegateway version.

Also does openlp cash the download verses from BibleGateway ?

Thanks and God bless
Stephen

Comments

  • edited January 2011

    The OSIS importer should take care of the Strongs numbers. If it isn't, file a bug about it.

  • edited January 2011

    Until now I only tried Chinese characters within songs and these are working fine. Just now tried with the Bible Gateway version of the CUV, but just weird ASCII characters.

    See here: http://matthiashub.de/tmp/openlp/1.9.4-chinese-characters-in-bible-problem.png

    It looks like a standard encoding problem, @raoul I can do tests if needed

    --
    matthias

  • mmjmmj
    edited January 2011

    Hi, I´ve had just some look into the code. Our parsing library BeautifulSoup  is not able to recognice encoding correctly because there is are invalid characters in the BibelGateway html files. I will look for a nice fix for this issue.

  • edited January 2011

    Hi

    The OSIS importer does kind of take care of the Strong numbers. I don'e see the Strong numbers in the final output, but there are spaces between Chinese character which it should not be there.

    @Matthias since you understand Chinese, maybe you can have a look at this, are you able to do someting in the OSIS importer to remvoe the space character (0x20) between Chinese character during import? It would be easier for Openlp to do it in the importer than I try to use regular expression to remove the space between Chiese character from the import source file. I also have a look at your screen dump, yes I got the same thing as well when I import the Chinese Bible from Biblegateway.

    Thanks and God bless
    Stephen

  • edited January 2011

    Hi

    Here is the error log I got when I import Opensong version of the Chinese Bible


    Traceback (most recent call last):

    File "/usr/lib/pymodules/python2.6/openlp/plugins/bibles/forms/bibleimportform.py", line 285, in onCurrentIdChanged

    self.performImport()

    File "/usr/lib/pymodules/python2.6/openlp/plugins/bibles/forms/bibleimportform.py", line 516, in performImport

    if importer.do_import():

    File "/usr/lib/pymodules/python2.6/openlp/plugins/bibles/lib/opensong.py", line 82, in do_import

    int(chapter.attrib[u'n']),

    ValueError: invalid literal for int() with base 10: 'of Solomon 1'

     

  • JTJT
    edited January 2011

    The OpenSong issue is fixed in trunk so should be in the next version of whichever method you use to get OpenLP.

    We're still working on the BibleGateway issue but as noted, the BibleServer version works so you should be able to use that fine as a workaround.

    Cheers, Jon

Sign In or Register to comment.