Can't play any videos

edited 1:55PM in Development

Dear all

We're now running OpenLP 1.9.5 on Ubuntu Lucid.  Most things are now working very well.  But one remaining problem is that we can't play any media.  Trying to preview or go live with any file results in a message "Unsupported file".  I've tried MP4, wmv, flv, mp3, ...  always with the same result.  Yet we can play these files with Movie Player (Totem), VLC, or from the command line with FFplay or mplayer.  It doesn't really matter as we can always play video clips independently of OpenLP (in fact we did so in yesterday's service), but I thought you ought to know.

Thanks

Andy

PS Is it best to report separate problems in separate threads, as I have done here?

Comments

  • edited May 2011

    Hi Andy,

    We are aware of this, and trying to figure out what causes this. In the mean time, there are a few packages you can install to try to get media going. First make sure you have "ubuntu-restricted-extras" installed, if that's not helping, install "kubuntu-restricted-extras".

    One other thing you can do is to uninstall the "phonon-backend-xine" or "phonon-backend-gstreamer" packages, and install the "phonon-backend-vlc" package, which makes OpenLP use VLC.

  • edited May 2011

    OK, I had ubuntu-restricted-extras and kubuntu-restricted-extras installed already.  And phonon-backend-vlc isn't in the Lucid repositories (it is in Maverick and Natty, and available from a PPA for Lucid).

    But I didn't need it.  I had phonon-backend-xine installed, and swapping that for phonon-backend-gstreamer cured the problem.  All the video formats I mentioned above now play.

    I tried playing them behind lyrics, but (a) it was very jerky and (b) the colours were all wrong (some brown cliffs turned blue!)  But I think you know that's not working yet.

    So thank you once again for your help - OpenLP is getting better and better!

    Andy

  • edited May 2011

    Yes, the choppy video in text-over-video is a known issue which we unfortunately don't have a solution to at the moment. Apparently it will be partially solved in Qt 4.8, but that's only coming out in about 4 months time, and will therefore only be available in 11.10.

  • edited May 2011

    I am also having a similar problem with Windows XP. using wma files that worked in version 1.2.6 we are not able to see a display on main or on the panel, Phonon is sleected. If I try and use a mp4 we got the unsupported but running MEdia player it did eventually work but the video lagged the audio.

  • edited May 2011

    SUCCESS after FAILURE!

    We're on Ubuntu 10.04 (which is Lucid, I think).

    While trying to get video working...

    At first I tried this:

    1. Install "ubuntu-restricted-extras"

    2. Remove "phonon-backend-xine"

    ...but that somehow removed OpenLP!

    Then I tried this:

    3. Re-Install "phonon-backend-xine"

    4. Install "phonon-backend-gstreamer"

    5. Re-Install OpenLP (thankfully all customizing and settings were still intact).

    ... and that succeded. It caused us to be able to view most media files. We encountered a .MOV file we could not play, but who knows what codecs it had need of.

    Thanks for the great software!

    Sincerely,
    Pastor Doug Joseph

  • edited June 2011

    Thank you very much Pastor Joseph!!...im having problem on how to play mediafiles in openlp.. now you solve my problem! thanx a lot!.. Godbless you more..! :)

Sign In or Register to comment.