openlp testing env video while openlp win32 no video

edited November -1 in Troubleshooting


This issue solved below



I've tried serveral clean installations of the win32 installer and I can't get video to show whether or not Phonon is enabled. Then I tried setting up a testing environment "" and that plays video with and without phonon. I'm not sure where to begin debugging this. Anyone have any ideas on how to fix this or atleast find the problem?



OS Name Microsoft Windows XP Professional

Version 5.1.2600 Service Pack 3 Build 2600

OS Manufacturer Microsoft Corporation

System Manufacturer Dell Inc.

System Model Inspiron 1720

System Type X86-based PC

Processor x86 Family 6 Model 15 Stepping 13 GenuineIntel ~1995 Mhz

BIOS Version/Date Dell Inc. A06, 1/14/2008

SMBIOS Version 2.4

Windows Directory C:\WINDOWS

System Directory C:\WINDOWS\system32

Boot Device \Device\HarddiskVolume1

Locale United States

Hardware Abstraction Layer Version = "5.1.2600.5512 (xpsp.080413-2111)"

Time Zone Central Daylight Time

Total Physical Memory 3,072.00 MB

Available Physical Memory 1.62 GB

Total Virtual Memory 2.00 GB

Available Virtual Memory 1.96 GB

Page File Space 4.84 GB

Page File C:\pagefile.sys



  • edited May 2011

    In order for most people to install OpenLP on Windows, we have to compile and build it so that Python, Qt and all the other it needs are built it. When you run OpenLP from a testing or development environment, it is running "natively" - i.e. without any bundling. This could be the reason.

    That said, a fair number of folks have had success playing videos using the Windows build. I cannot say why or what their setup is, as I use Linux, but maybe someone else who runs Windows can comment and tell you what they did.

  • edited May 2011

    Ok. So I was able to hear the sound of videos but not see them. The transparent window that was supposed to show the video was there, but no video. I was able to get it to work by installing ffdshow, then configuring/enabling the decoding for the video I was trying to view. Specifically mapping all the wmv codec to wmv9. So ffdshow is necessary for making it work.

Sign In or Register to comment.