Disable/Toggle Projector Feed

G'Day

We've been using OpenLP for a few weeks and it works reasonably well in our environment. We especially appreciate the implementation of how scripture verses are displayed - it knocks the socks off all the paid versions we've compared/trialled.

The one sticking point is that a number of our speakers are heavily entrenched in the ways of PowerPoint ... in particular, the use of transitions/automatic timings. As a result, when projecting such presentations, we have to exit OpenLP in order for PowerPoint to grab focus, and execute as desired.

Is there a way to disable the OpenLP projector feed, so that instead of exiting OpenLP, one could simply disable the feed, minimise OpenLP, run PowerPoint which then has the projector focus, quit the PowerPoint when complete, return to OpenLP and re-enable the feed?!?

We've seen this implemented in the Worship Him Power Edition software when we trialled it.

 

Thank-you for your time.

Comments

  • edited April 2012

    Hi there,

    Well for me automatic PowerPoint timings normally work OK, even when starting from OpenLP, so I'm sorry you're having trouble. If you need to give PowerPoint focus, then after starting it from OpenLP you should just be able to click the  "PowerPoint Slide Show - [filename]" icon in the Windows Taskbar, and focus will return to PowerPoint. 

    If you decide you still want to start PowerPoint from outside OpenLP, then you don't need to exit OpenLP. On the toolbar in the slide controller there is a the Blank Button. Next to this is a little arrow, if you click this you'll see the "Show Desktop" option which you can select. This will then allow any other apps to show as normal on the second monitor. 

  • edited April 2012

    We have never had a problem running a PowerPoint file that was added into the service. Timed or using a remote work great. 

    Did you try adding it to the service and running it?

    John

  • edited April 2012

    I'm not sure about PPT but I can open both OLP and Impress on my computer. In Impress I go to the slideshow settings and make sure the "Presentation Always On Top" box is checked. Then I run OLP and when I want to go to the Impress pesentation I just hit F5 and it goes directly to the first slide and Impress is up and running. When I am done with the presentation and exit it goes directly back to the OLP slide that was running when I left. It is seemless and I don't have to do anything to OLP. Not sure if there is a presentation on top setting for PPT but you might want to look for it.

  • edited April 2012

    Thanks for the reply.  I'll be testing out your suggestions at the next available opportunity.

    When running powerpoint with transitions, the transitions end up off the screen, and overlayed on the text displayed before the transition - when executed inside of OpenLP ... PowerPoint on it's own works as expected.

    This is currently happening on a Thinkpad T61 with Windows 7 x64 / Office 2007 ... given some of the other responses, perhaps there is a problem with the software build.

    I am nearly ready to do some more testing with a clean build on a desktop.

    Will advise outcome once done.

    Thanks to all for their replies/suggestions.

     

Sign In or Register to comment.