Presentations not showing since upgrading from 2.0.3 to 2.0.4

edited February 2014 in Troubleshooting
I'm having difficulty showing powerpoint slides after upgrading from 2.0.3 -> 2.0.4. It seems the presentation plugin is showing it's active but for any powerpoint slideshows in the service manager they have a red cross next to them and they can't be opened. I originally installed 2.0.4 over the top of 2.0.3 but after coming across the problem mentioned above I uninstalled then tried installing 2.0.4 without any resolution.
I'm running Windows 7 Pro 64-bit with Office 2010.
Perhaps it's because OpenLP 2.0.4 doesn't seem to run as administrator... To test this, go to File --> Export --> Settings and save to the Desktop. Version 2.0.3 will let you, but version 2.0.4 won't. This is the case even though I have UAC turned off and right-clicked the setup.exe and clicked on 'Run As Administrator' to install.
Is anyone else getting the same things?

Comments

  • Hi Marty,

    I'm not a Windows user, but I've puzzled over your post for a few days now. I have no idea why OpenLP would do this (it doesn't do it on Linux or OS X), so I can only imagine it is Windows interfering. I unfortunately don't know how to fix it.
  • Marty, I'm with raoul I don't use windows, but have you tried deleting the presentations and adding them again? I seem to recall having some issue and this fixing it in the past with some other items. I would say odds are slim of that helping but might be worth a try.
  • Raoul, I think one of the problems is that, on real operating systems, when something like this happens, you will get a system log file entry saying permission denied, which is usually a clue as to why something is not working. 

    Marty, what I would do, is open a DOS command line screen, then run OpenLP from there, with debug mode on, add

    >openlp.log

    to the end of the command, and it will put the debug messages into the log file.  Load the file into notepad, and look for the word permission.  If your lucky you will find a message that will help out.

  • edited February 2014
    Hi Marty,

    I am the person that does the Windows builds.  I've looked at this problem and um-fortunatly I cannot duplicate it.

    I reinstalled OpenLP 2.0.3 on 2 different machines, one running Windows XP and the other running Windows 7 Professional.  I loaded 3 different PowerPoint presentations and all three displayed with no problem.

    You said you are using Office 2010.  Are the presentations saved as 2010?  I do not have the 2010 version to test with (just 2003 and 2007).  Perhaps you could try saving them in 2007 format (if possible)

    I then installed OpenLP 2.0.4 and the presentations ran fine.

    I also created a non-admin user account and ran all of the above, including saving settings to the desktop, with no problem (which has me concerned that the is another underlying problem).  Can you save anything to the desktop?

    Also, try reinstalling 2.0.3 and see if this corrects the problem.

    Steve
  • Check that when you open the Microsoft Presentation in Office it does not display the yellow enable editing bar. This may be what is stopping it - it has really messed up mail merging for me at work. It is the Microsoft Trust Centre settings. 

    OR If it is not that then right click the presentation, click advanced settings and click the Unblok button. This may be causing your issue.
  • Hi Everyone,
    Thanks so much for offering your suggestions and advice on what to try. Guess what - I have it all working now and it has nothing to with OpenLP... I had an anti-virus/firewall program running that didn't recognise the new software and 'isolated' the program: Comodo Internet Security.
    So now I've told this Comodo Internet Security software to 'trust' OpenLP 2.0.4 and let it run without 'isolating' it.
    Sorry to trouble you all but I do appreciate the time you all took to check this out. All good for now!
    Marty
  • Yay! Glad it turned out to be something small and simple.
Sign In or Register to comment.