OpenLP hangs at logo

edited March 2014 in Troubleshooting
I have just installed OpenLP 2.0.4 on ubuntu 1404. Everything is fine until after I have completed the first set up wizard and it goes to open OpenLP for the first time and it just gets stuck with the OpenLP logo showing and nothing happens.

Has anyone else found this and is there a work around?

Comments

  • Hi Scio

    Could you try to run it with debug-logging on an post the log to pastebin.com?
    You enable logging by running it from the commandline like this: "openlp -l debug".
    The placement of the logfile is written in the console when you run the command.
  • This is a known issue, but we have been unable to reproduce it ourselves. We suspect it is related to the graphics card. But first we need some more information:
    • What operating system are you using?
    • What graphics card are you using?
    • If you're on Linux, do you have the open source or proprietary drivers installed (nVidia or ATi)?
    • If you leave OpenLP for a while (like 10 minutes), does it eventually start up?
  • A few other folks recently mentioned that after an initial update of their software on Ubuntu 14.04, OpenLP worked again, perhaps you have the same issue?
  • Sorry it has taken me a while to reply. Here are the answers to your questions;
    I am using Ubuntu 14.04.
    Running on an intel 4400 graphics card (The laptop also has a nvidia graphics card 750m as well).
    I am using the intel card to run OpenLP on so am using the open source driver.
    When I left it for a while it didn't start up.

    I ended up reinstalling ubuntu for another reason and when I reinstalled OpenLP everything worked fine.
  • edited July 2014
    The same thing happen to me in MBP, after successful downloading and installing the first time it will run will display the logo and nothing happen.
    If it will try to re-launch the OpenLP, this will ask me for a dialog box, OpenLP is already running. Do you wish to continue? No Yes.
    If you select yes, same thing is going to happen icon will continue to bounce up and down the icon will disappeared and nothing is going to happen.
    I have tried the solution I saw earlier using the terminal window and gained nothing. 

    Any idea how to resolved this?.
  • I am having the same issue as well.  

    When I first installed the program, it took several tries before it finally reached 100% install.  When I did finally get to that point, it will only show the splash logo and then it disappears.  I checked the task manager and it is not running or trying to run.  

    Here is my info and log:

    • Operating System?  Windows 8.1 Pro
    • What graphics card are you using? XFX Radeon R7770 running Catalyst 14.4 drivers
    • Version of OpenLP?  2.0.5
    • The exact steps to take in order to reproduce the error?  Open from Start menu both OpenLP & OpenLP (Debug).exe.  Neither respond after splash screen.  I tried opening as administrator for both, as well, to no avail.
    • Version of OpenOffice? 4.1.0
    • What Bible translation and type you are importing. Tried ASV, KJV, both, and none.  I also have my own that I placed into the folder (in sqlite3 format). That didn't help either.
    • If you leave OpenLP for a while (like 10 minutes), does it eventually start up? No
    • Log: http://pastebin.com/9JNk8Zmb
    Downloaded an earlier version, but never got a chance to really dig into it.  I liked what I saw though, and can't wait to take it for a spin.

    Thanks and God Bless
  • Ronnie,

    There seems to be a problem with one of your themes. Try deleting "C:\Users\Ron\AppData\Roaming\openlp\data\themes\Moss_on_tree.otz" and then see if OpenLP starts up.
  • Sitting in the Sanctuary on day off, trying to get us up to speed.  Elderly EasyWorship not cutting it.  Having troubles with what looks to be a fantastic program, but can't get it going.

    I am unable to start the latest OpenLP which I have just downloaded.  It stops instantly at the splash/logo.


    OS:  Windows 7
    Graphics: Radeon x300/x550/x1050 Series
    OpenLP: 2.0.5
    Reproduce Error: Open from Start Menu and Debug.  Crash on splash.
    Office:  Microsoft Office 2003
    Bible: KJV, ASV
    Does not start up ever.



  • Follow up:
    I've uninstalled.  Upon reinstall, I cannot even choose Bibles, Themes. etc.  Crashes immediately on splash/logo.
  • Hi Robert, please turn of Windows error reporting, and then launch OpenLP again. Windows is hiding the error from us.

    http://www.addictivetips.com/windows-tips/how-to-disable-error-reporting-in-windows-7/
  • Raoul 

    I still cannot start the OpenLP on my Mac, I run the OpenLP from the directory itself and this is what I got.

    /Applications/OpenLP.app/Contents/MacOS/OpenLP ; exit;

    Traceback (most recent call last):

      File "/Users/martin/Projects/openlp/OpenLP-2.0.5/build/pyi.darwin/OpenLP/out00-PYZ.pyz/openlp.core", line 228, in event

    AttributeError: 'OpenLP' object has no attribute 'mainWindow'

    2014-08-19 20:45:23.270 OpenLP[1220:507] modalSession has been exited prematurely - check for a reentrant call to endModalSession:

    logout


  • Yes, and I stop at this step, 
    Can you try running "spctl --remove /Volumes/OpenLP/OpenLP.app" then "spctl --add /Applications/OpenLP.app/" and then try launching OpenLP with Gatekeeper enabled?

    It cannot find the volume, so I stopped right here and delete/uninstall the whole application by "AppCleaner"

    I have this running before in Mountain Lion when I have just upgraded in Maverick it never work at all. I guess I will have to give up trying this and focus on Easyslides for Windows.

    Thanks.
Sign In or Register to comment.