Remote doesn't connect using OpenLP Portable version?

edited May 2014 in Troubleshooting
Found this amazing application OpenLP and have implemented it in our
church.  I use my Android Tablet and Phone to control the service and it
works great.  However, to simplify the creation process I prepare the
services on my home PC using the Portable version of OpenLP and assumed
that I could simply plug in the drive at the church and run the portable
app and not worry about databases, themes etc.  Only problem is the
remote option doesn't seem to work using the Android app or through a
browser on my remote computers all on the same network. Doesn't seem to
matter if I'm using my Android devices or a Windows PC, the remote
address for the OpenLP running in the Portable installation can't be

If I run the OpenLP installed on the church PC the remote and Browser remote functions work fine but I have to deal with the databases etc.

Is this a known issue?  Is there something I can do to get the Portable OpenLP to work with the remote?


  • Hi JimT,

    We have not encountered this problem yet. Could you help us by seeing if you can find your log file please? See the entry in our FAQ:

    Also, have you made sure that your remote plugin is enabled, and that you are connecting to the correct IP address (check the remote settings).
  • I read through the link but it seems to require that I run OpenLP in debug mode.  I can't seem to find out how to run OpenLP Portable in debug mode.  Is there a command line or options that I would need to run the Portable OpenLP with?

    I can confirm that the Remote Plugin is enabled in both the installed version of OpenLP and the Portable version.  The IP address is correct in both the installed OpenLP and the Portable versions.  The same happens when I try this on my Home PC running Windows 7 and the church PC running Windows XP.  I have tried running the Portable version of OpenLP on a 64gb usb thumb drive and on a 1tb usb hard drive.  I also copied the OpenLP Portable folder onto my Home PC and the church PC and ran from the system drives.  When I start the Android Remote application before starting OpenLP Portable, nothing appears on the Android remote screen, but when I close the Portable OpenLP and start the install version of OpenLP the Service appears on the Android screen.  Must be something missing from the Portable version or the Firewall is blocking something.  I disabled the Firewall on both PC's temporarily and Allowed the Portable application but it still doesn't work.
  • So, is there any way to run in debug mode with the Portable version of OpenLP?

  • I added the word debug to the shortcut I use on my PC to start the Portable version of Openlp installed on my usb drive.  I looked and there is no "debug" file on the usb drive.

    Remote Android app still doesn't connect to the Portable version of OpenLP with all the correct IP and port settings.

    The IP settings work if I run the Portable OpenLP and then control the Service using the IP address and port ( in a Browser window but only if it is on the PC running the OpenLP service so it's not a real remote.

    As a work around I started the Android iDisplay on my tablet and PC turning my tablet into an additional monitor for my PC.  Running Chrome on the iDisplay monitor on my Tablet allowed me to remote control the Portable OpenLP but it was a little slow switching between Service and Live screens.

    Noi problems at all if I use the same IP and Port settings on the installed Windows version of OpenLP.
  • You need to add a "-l debug" (that's a lowercase L, not a one).

    I don't have Windows, but I asked one of the Windows guys to try to reproduce your problem. The good news is that he was able to reproduce it, the bad news is that he was unable to reproduce it reliably. We're looking into it.
  • edited May 2014
    Hi Jim,

    I am the Window and Portable builder. 

    I tested your issue and the connection only failed when the Windows firewall blocked the connection.  I let the firewall allow OpenLP portable to access the network, and all runs fine.  Please insure that the firewall is set to allow "OpenLPPortable.exe" access to the network.

    I have tested this with the portable version running on both Windows XP and Windows 7

    I discovered that there may be multiple entries in the windows firewall with the name "OpenLP".  To get a reliable connection I

    1.  Deleted all the entries in the firewall.
    2.  Started "OpenLPPortable.exe"  from an SD card after doing the portable install.
    3.  When the firewall screen popped up I selected both "Home/work (Private)" and "Public" networks as allowed.
    4.  Since my laptop has both a Wireless and Wired connection I went to Openlp/Settings/Configure OpenLP and clicked "Remotes"
    5.  I used the IP address shown as "Remote URL:".  This is the address/port OpenLP is listening to: in my case it was .   Server IP Address should be
    6.  Make sure the Android app is set to the same.
    7.  I made a Debug Log but it showed nothing useful.

    I have tested this on both Windows XP Pro (SP3) and Windows 7 Pro 64 Bit (SP1).
    I installed OpenLPPortable_2.0.4.paf.exe.
    My phone is a Samsung Galaxy S3 running Android 4.4.2


  • edited May 2014

    In response to your database issue I have the same problem.  Here's what I do:

    1.  I copy the contents of the "openlp data directory" to an SD Card directory. "OpenLP_Data_Backup".  You can open the directory from "OpenLP/Tools/Open Data Folder".
    2.  If you want to copy the OpenLP settings go to "OpenLP/File?Export/Settings"  Save the setting file on the SD Card.  Use a name like "ChurchSettings"
    3.  When you get home, copy the contents of the SD Card "OpenLP_Data_Backup" to the openlp data directoy (replacing everything that is there.
    4.  Import the settings file by going to "OpenLP/File/Import/Settings" and select the file "ChurchSettings.conf" on the SD Card.
    5.  If you want the portable version to use the same files as the Church, copy the backup data file to:  "SD Drive letter\OpenLPPortable\Data

    I have created some BAT files to automate this process of copying the data files.  I can get them from Church Sunday and post here if you want me to.


  • To add a parm to OpenLP Portable you need to edit the file:


    Where "..." is the Drive\Directory of the portable installation.

    Edit the line:


    To produce a debug log, the line would be:

    CommandLineArguments="-p -l debug"

    The logfile is produced in the directory:


  • I have Vipre Security looking after the Firewall and have excluded OpenLPPortable.exe but doesn't work on my Home PC.  On the church pc it uses the Windows XP Firewall and OpenLPPortable.exe is supposedly Excluded as well.  Funny that I didn't need to set anything Firewall settings for the Installed OpenLP application to allow the remote on any of my PC's.

    I seem to have found a workaround that may be working.  I have OpenLP installed on both my Home PC and Church PC and I've edited the OpenLP.ini files for both installations pointing to the Data folder on my USB drive "data%20path=P:\\OpenLPPortable\\Data"

    Seemed to work today, so will stick with this for a while rather than working with the Portable App.
Sign In or Register to comment.