Mac: OpenLP startet nicht

edited July 2014 in Deutsch (German)
Hallo,
ich habe schon im Forum nach einem bestehenden Thema gesucht, aber habe keine richtige Lösung gefunden.
Mein Problem: OpenLP startet nicht mehr. Das ICON ist im Dock zu sehen, es springt eine Zeit und dann hört es auf und es passiert nichts.

Mein MAC: OS X 10.9.3 Mavericks
2,66 Intel Core Duo
4GB RAM

Ich habe auch schon versucht auf einem Macbook Pro OpenLP zu upgraden. Funktioniert auch nicht. Es hat immer funktioniert, aber nach dem 2.0.4 Update funktioniert nichts. Nichtmal ein Downgrade auf 2.0.3, das immer funktioniert hat.

Comments

  • Hi newidea....

    habe ebenfalls das OpenLP (offenbar die neuste verfügbare Version) heruntergeladen, das DMG-File durchlaufen lassen...Es läuft aber nicht bis zum Schluss durch und es erscheint eine Bug-Meldung...

    Wie hat sich dies bei Dir erledigt???

    Vielen Dank für einen Hinweis...
  • OpenLP 2.2.0 hat einen Bug, der verhindert, dass OpenLP mit der Spracheinstellung Deutsch gestartet werden kann: http://openlp.org/blog/2015/10/23/translation-errors-and-the-big-oops
  • Hallo Zusammen,

    jetzt gibt es die Version 2.2.1.
    Die sollte das Problem beheben. bei war das der Fall, auch wenn ich kein MAC-User bin. Dennoch hatte ich das selbe Probelm.

    Gruß Questions
  • edited October 27
    Hallo,

    da ich keinen anderen Thread zum Thema gefunden habe, mache ich den hier nach drei Jahren noch mal auf:

    Ich habe ein ansonsten gut laufendes, recht frisches Linux Mint 19 am Start, habe gestern aus dem Repository das dort aktuelle OpenLP (2.4.6-1) installiert und beim versuch es zu starten passiert: - Nichts! Aber wirklich gar nichts! Selbst die HDD-LED am Rechner flackert nicht einmal.

    Die Sprache auf Englisch zu drehen habe ich versucht, brachte aber im Bezug auf OpenLP keinen Unterschied.

    Hat jemand eine Ahnung, wo das Problem sonst noch liegen könnte?

    Nachtrag:
    Interessanterweise habe ich jetzt einmal unter dem selben Linux mit VirtualBox ein "Unter"-Linux Ubuntu Mate gestartet. Die Installation ist in Englisch. Hier habe ich OpenLP installiert und hier funktioniert es offenbar einwandfrei. Kann es sein, dass die Sprachproblematik doch nicht richtig repariert wurde?
  • Haaalllooo...? Lebt dieses Forum noch? Oder bin ich der einzige OpenLP user unter Linux Mint, der dieses Problem hat?

    Ich habe nämlich festgestellt, dass das Problem offenbar generell unter Linux Mint auftritt. VIelleicht fehlt hier ein Standardpaket, welches auch bei der OpenLP Installation nicht mitkommt.

    Falls sich also do noch jemand findet, der hier weiter helfen kann, das wäre prima!
  • @antineff kannst du mal versuchen, openlp von der Konsole aus zu starten? Da sollte einfach "openlp" in die Konsole einzutippen und mit der Umschalttaste bestätigen reichen.

    Da sieht man dann wahrscheinlich einen Fehler, wenn du den hier postest kann ich mal schauen ob ich sehe woran es liegen könnte...
  • Danke für das Feedback! Ja da kommt tatsächlich eine Fehlermeldung, die darauf hinweist, dass offenbar etwas fehlt. Die Details entziehen sich aber meiner Kenntnis.

    Traceback (most recent call last):
      File "/usr/bin/openlp", line 27, in <module>
        from openlp.core.common import is_win, is_macosx
      File "/usr/share/openlp/openlp/__init__.py", line 26, in <module>
        from openlp import core, plugins
      File "/usr/share/openlp/openlp/core/__init__.py", line 43, in <module>
        from openlp.core.ui.mainwindow import MainWindow
      File "/usr/share/openlp/openlp/core/ui/mainwindow.py", line 29, in <module>
        from distutils import dir_util
    ImportError: cannot import name 'dir_util'

    Hoffentlich sagt dir das mehr! Danke für deine Unterstützung!

  • See https://forums.openlp.org/discussion/comment/11584#Comment_11584
  • Super! Die fehlende Python Bibliothek war's! OpenLP läuft! Ganz herzlichen Dank!
Sign In or Register to comment.