Is it possible to select frammebuffer fb1 as output display?

There are fb0 and fb1 on my raspberry, but I need display for main program and other display for output.

I started openlp on fb1 as FRAMMEBUFFER=/dev/fb1 startx /opt/openlp/

Second question: how can I start program with default image or blank on live?




  • Hi Tomas,

    First of all, you should know that OpenLP will be quite slow on a Raspberry Pi. It will run though.

    I don't really understand what it is you are trying to do with the framebuffers... The Raspberry Pi has 1 HDMI output, will you use that? Are you using virtual framebuffers? Could you try to describe your setup in more details?

    You can set a default background picture under settings, which will then be shown on startup.
  • Hi tgc,

    OpenLP started quite slow but then lyrics and bible presentation is very good via remote control.

    I have one output on s-video and second tft-display via gpio and sometime another as vncserver.

    I need start openlp on tft (or via vncserver) and output to s-video.

    I set background picture under advanced setting, but programs start and "live" seems to be set as "Show desktop" without start live presentation


  • I can confirm that the background picture doesn't show on startup in the development version - we'll try to get it fixed.

    While I do have a Raspberry Pi myself, I've never used it like that, so I'm afraid I can't help you with that. You'll probably have more luck in the official Raspberry Pi website forums.
    An alternative setup could be to use only 1 monitor where the output (lyrics/text/etc) is shown and then use web-remote or android app for remote control.
  • Hi again

    Just a quick follow-up on OpenLP not showing the live presentation window at startup. I've been told (and have confirmed this in tests) that the live presentation window will not open on startup if it is set to go fullscreen on the same screen as the OpenLP application window. This actually makes perfect sense, because otherwise you wouldn't be able to get to the OpenLP application window...
Sign In or Register to comment.