Strange behaviour with Impress on Ubuntu 12.04 and OpenLP 2.0.5

I have recently updated our projection PC to Ununtu 12.04 (was 10.04) and openLP to 2.0.5 (was 1.9.x). After the update everything works as normal except presentations (I have libreoffice 3.5.7 installed). 

The strange behaviour I get is as follows:

* libreoffice opens when I select the presentation (odp) in the service. This is the full initial page of libreoffice like when you type 'soffice' at the command line.

* I can select presentation (ie Impress) and it then shows me a blank (untitled) presentation

* I can iconize impress and then click on the live presentation and it displays on the primary display and not the projector display

* If I go to the Slide Show Settings in Impress I can see the display is set to Display 1 (primary). If I select Display 2 and click on the presentation is goes to the projector but this never saves and will revert to the the other display when you move to another service item.

Is there some way to tell openLP to:

* use some kind of view mode instead of fully opening the libreoffice program

* use the other display (ie not the primary display)

Any help will be appreciated.

Regards

Errol

Comments

  • Would it be worth going to 2.1 beta? If so, do I also need to go to Ubuntu 14.04?
  • Try installing the "python-uno" package?
  • Hi Raoul

    I have python-uno installed

    Errol
  • I have found and fixed the issue.

    It seems that the problem is the option string passed to libreoffice by openLP. 

    There are 2 things that needed to change.

    * the options need a -- and not - (eg --minimized and not -minimized)

    * the additional option --invisible is needed

    The full options code that works (changed in the file openlp/core/utils/__init__.py)

        OPTIONS = u'--invisible --nologo --norestore --minimized --nodefault --nofirststartwizard'
        if UNO_CONNECTION_TYPE == u'pipe':
            CONNECTION = u'"--accept=pipe,name=openlp_pipe;urp;"'
        else:
            CONNECTION = u'"--accept=socket,host=localhost,port=2002;urp;"'
        return u'%s %s %s' % (COMMAND, OPTIONS, CONNECTION)

  • I know this is a very old thread but I too was having issues like this. My __init__.py file was slightly different to the above (I have no = u' but just = '
    I found adding --invisible did not help but did discover that the nostartwizard apparently does nothing (is only a valid option for compatibility reasons) and that nologo is implied by invisible.
    I reasoned therefore that OPTIONS = '--invisible --norestore' should be enough although perhaps --nodefault may be needed. The thing that finally fixed my setup was turning off, in impress settings, use presenter mode. Unfortunately I could find no no option I could add to turn this off from the command line so have to have leave it turned off in settings.
    Impress still behaves oddly - but is at least usable now.
    Kubuntu 18.04 OpenLP 2.4
Sign In or Register to comment.