Python3 Packages Needed for OpenLP 2.1.5 Release Candidate 2 Source Code

I just installed a new Linux distro, and I'm trying to get OpenLP to run. The old distro (on a separate partition of my hard drive) has a long list of python3 packages, and I would prefer not to load the new distro with items I don't need. I've added some packages to eliminate some errors, but I'm stuck with this one:
File "/mnt/bigone/OpenLP/openlp/core/common/__init__.py", line 32, in <module>
    from ipaddress import IPv4Address, IPv6Address, AddressValueError
ImportError: No module named ipaddress

I added python3-ipaddr and python3-ipy, but the error persists.

Lane

Comments

  • Hi Lane,

    Normally you should be told what is missing by running the check_dependencies.py scritpt, which can be found in the scripts folder.
    What distro did you install, and which python3 version are you using? OpenLP 2.1.x requires Python 3.3 and newer - though it hasen't been tested with the the unstable python 3.5.
  • Thanks for the note about dependencies. I did notice on the LXLE distro that it's running an older version of Linux and the python is only 3.2.

    Lane
  • edited August 2015
    OK, I'm now on a newer distro, KaOS which has Python 3.4. When I ran OpenLP, it complained about a missing PyQt, so I installed that. Then I got an error about the missing lxml module. The package repository didn't have an lxml for python3, but I discovered that python2 had an lxml module version 3.4, so I copied it to the python3 folder. That got me to this error:








    Traceback (most recent call last):

     File "./openlp.py", line 27, in <module>

       from openlp.core.common import is_win, is_macosx                  
     File "/mnt/bigone/OpenLP/openlp/__init__.py", line 26, in <module>                                                        
       from openlp import core, plugins
    File "/mnt/bigone/OpenLP/openlp/core/__init__.py", line 41, in <module>                                                   
       from openlp.core.lib import ScreenList
    File "/mnt/bigone/OpenLP/openlp/core/lib/__init__.py", line 326, in <module>                                              
       from .htmlbuilder import build_html, build_lyrics_format_css, build_lyrics_outline_css                                  
     File "/mnt/bigone/OpenLP/openlp/core/lib/htmlbuilder.py", line 395, in <module>                                           
       from openlp.core.lib.theme import BackgroundType, BackgroundGradientType, VerticalType, HorizontalType
    File "/mnt/bigone/OpenLP/openlp/core/lib/theme.py", line 31, in <module>                                                  
       from lxml import etree, objectify
    ImportError: dynamic module does not define init function (PyInit_etree)      




    Is there any hope?

    Lane
  • Hi Lane,

    You can't copy packages from python2 to python3 like that, they need to be built for either python2 or 3.
    Why not use one of the ubuntu based distros if you want to get up and running quickly? There is Kubuntu if you want KDE and Xubuntu of XFCE, lubuntu for LXDE and ubuntu GNOME you you want gnome.
    Using ubuntu you can install directly from our development PPA: https://launchpad.net/~openlp-core/+archive/ubuntu/dev
  • Thanks for clearing that up.

    Speaking of distros, I currently have four of them installed on my hard drive. It's a bit of a hobby to try out different ones. Three of them are Debian-based: Debian, LXLE, and ExTIX. The only one that isn't, and in which I guess I won't be running OpenLP, is KaOS. Its appeal is that it's running a bleeding-edge version of KDE and is very attractive.

    I'll just have to boot to Debian when I want to prepare the church files. I am able to run the development source directly there.

    Lane
  • I'm trying to run OpenLP in a new distro: LXLE 14.04, which is based on Ubuntu 14.04 (Trusty). I installed
    OpenLP 2.1.6 Release Candidate 3 for Ubuntu 14.04 and up. It backed up the data and then crashed. I've emailed the crash report.

    I downloaded the source for the above, and it generated the same errors as above.

    So I tried to install
    OpenLP 2.0 for Ubuntu. I added the release PPA, but Synaptic still only shows the 2.1.6 I already have installed.

    Lane
  • Lane, run the check_dependencies.py script in the "scripts" directory.
  • Raoul, I now have OpenLP 2.1.6 Release Candidate 3 running in LXLE 14.04. I was running a 64-bit version of this distro, and I'm now running a 32-bit.

    2.1.6 Release Candidate 3 is also running well in the Windows 7 computer at church.

    Thanks for the help!

    Lane
Sign In or Register to comment.