Songs order

First of all, God bless you for the work that you are doing at this app.

I have like 1300 songs. The problem is that when i search the song numbered 3, it gives me a list like: 1003, 1013, 1023, 103, 1030... and it is hard to find the song named 3.  Isn^t there an option to order the songs like: 3, 13, 23, 30, 33, 43... and so on?
Like 1, 2, 3, 4, 5, 6, 7, 8, 9. Version is 2.0.5


  • Hi Sebi,

    I am not sure if I am interpreting this correctly.
    You mean you have your song Title as a number or where/how do you number your songs?
    Have you perhaps tried "0001", "0002", "0003" etc without quotes to see if that helps?  Keeps it unique that way & you can get to it immediately.

    Have you tried using the portable development version 2.1.6 to see if it is solved in that version?  If it is solved in that version, then in the upcoming soon-to-be-released stable version 2.2, it will remain fixed as well.

    Could you also advise us the platform you are using it on like Windows 7, Ubuntu, Mac etc?
    I am not the developer, just an end user like you.  I am on Windows and could try to replicate your scenario and see how it works in your environment.  But I need more inputs from you as I am not sure what you mean by "song number".
  • I have been trying to edit songs or add songs to the database and have been typing the info in ( name of song,author,book & number ).I have tried with O worship the King which is 6 verses long and when it comes to previewing the sonng,only v1 shows up instaed of all of them.When I edit I get the message that verses should be in order as follows V1 , V2 , V3 , V4 , V5 , and V6  which I have done,but still not.I am using Windows 8.1 and Mozilla Firefox 41.0.2
  • edited October 2015
    Hi Neil,

    I have created 2 screenshots of something you can try out to see if it works for you.  I am just guessing the tags may be incorrectly coded.  I may be wrong.

    The "Verse Order", just try leaving it out blank for now and see the results.  Do report back your findings as someone else could be facing similar issues and your validation/findings may help someone out.

    One thing not mentioned in your post is the version of OpenLP you are using.  Would be helpful to us to assist you.
Sign In or Register to comment.