Projector Manager panel and PJLink errors

First of all, a massive 'thanks' to the development team for including the projector control feature in the new release - I've been looking forward to using this and it has the potential to be really useful to us.

However, we are experiencing a few problems with it and I just want to check if these are known or not. 

I can only get it to work if authentication is not turned on. The error message below is reported whether using a real projector or running against the official PJLink software test suite if any password is required:

Traceback (most recent call last):

File "/Users/raoul/Projects/OpenLP/OpenLP-2.2.1/openlp/core/lib/projector/pjlink1.py", line 348, in check_login

AttributeError: 'str' object has no attribute 'encode'


In addition, if I simulate a warning or error on the projector (such as bulb failure) (using the PJLink test suite), then I get one of the following when clicking on the projector information icon:


Traceback (most recent call last):

  File "/Users/raoul/Projects/OpenLP/OpenLP-2.2.1/openlp/core/ui/projector/manager.py", line 676, in on_status_projector

KeyError: 'E_WARN'


Traceback (most recent call last):

  File "/Users/raoul/Projects/OpenLP/OpenLP-2.2.1/openlp/core/ui/projector/manager.py", line 676, in on_status_projector

KeyError: 'E_ERROR'


On a more minor note, the 'Help' button on the 'Edit Projector' dialog doesn't seem to do anything.


I hope these are easy to resolve as we would really prefer to run our network connected projector with some security on it. I'm running Mac OS X 'El Capitan', but I got the same error with authentication from a Windows 7 PC as well.


Howard.


Comments

  • Hi Howard,

    There's a bug in the code, which we've found and patched. When the new 2.4 release comes out at the end of January, it'll have this fixed.
  • Thanks Raoul, that's good to know!
    Let me know if you need any testers for the new version.

    Thanks again.

    Howard.
  • Well I've only just got around to upgrading to 2.4.1 version and the bugs I reported back in December are still present. Using Projector Manager with authentication enabled is broken.

    When attempting to connect to a password protected projector (but with no password provided in OpenLP) the following message results:

    Traceback (most recent call last):

    File "openlp/core/lib/projector/pjlink1.py", line 348, in check_login

    AttributeError: 'NoneType' object has no attribute 'encode'


    If I provide the correct password no error message or connection results. The connection icon does not change.


    I have checked this with our own projector and also with the official PJLink test software.
    Projector error conditions are still not being trapped with suitable error dialog as initially reported.

    I can see a couple of bugs in this area have been reported but I can't tell if these are among them.

    Howard.
  • Thanks for letting us know, Howard.
  • edited June 2016
    Howie - Could you provide a log output so I can check it out?

    To enable logging, open a terminal window, then enter "openlp -l DEBUG" 
    (Note  that it is a lowercase 'L')

    It will then tell you where the log file will be saved at.

    With DEBUG, there will be a _lot_ of output saved to the file, so may have to attach it or send it via pastebin.
  • OK, the log file is here: http://pastebin.com/B9d2yLp1

    This contains two connection attempts to the projector. One with no password supplied when one is required and then another with the correct password. With the correct password the connection is not accepted and the connection icon does not change.
  • I'm looking into the problem.

    First problem is authentication is failing due to mismatch in the hashing - looking at it.

    Second problem (no pin when authenticated connection requested) should have generated an error message box rather than generating an exception - looking at that as well.

    Thank you for your feedback - I'll try and fix it as soon as possible and get the fix in both trunk and current stable releases.
  • Thanks HowieG - both problems should be solved now. Just waiting for the fixes to get pushed into the next update.

  • Thanks that's good to know.

    While you've got the hood open, can you also make sure that projector errors such as bulb failures, filters needing replacement, etc are also correctly caught when clicking on the Projector information icon.

    Thanks

    Howard.
  • Projector errors (i.e., filters, lamps, etc.) are not errors per se in the program, but they are reported in the info tab. Should not be a problem, but I will run some extra tests to verify the information that is reported. I have a test emulator program, but haven't setup a lamp/filter failure mode in it yet.
  • By the way - i there is a bug like the two you reported, it would be helpful if you posted a bug report at

    That way we can keep track of when it was found as well as extra notes between devs when a problem arises.

    Thank you again for helping us to improve OpenLP for the user.
  • Also having a similar problem in v2.4.6  when attempting to connect to JVC LX-WX50 projectors.  Any Help would be wonderful.

    Traceback (most recent call last):

    File "openlp\core\lib\projector\pjlink1.py", line 400, in get_data

    UnicodeDecodeError: 'ascii' codec can't decode byte 0xee in position 10: ordinal not in range(128)

Sign In or Register to comment.