v2.4 Clicking on certain items in service manager doesn't send them to live as in previous versions

Hi there, we have just upgraded to 2.4 and have noticed one major issue which we cannot resolve. (Windows 10, PowerPoint 2010, VLC)

1. In previous versions, we could click on an item in the service manager and it would send it straight to live.  It will now do this for the first song clicked, but if we click on a next song, we have to click the blank screen Icon in the live section on, then off again before it appears on the screen.  It's the same going to an image and if we have a sequence of images in a loop, it will only display the first image in the loop.

However, if we have media or PowerPoint, we can click them and it will display the and also the next selection following these types of item.

2.  The same problem, but with the arrow keys.  If we work through our service in the service manager using the L & R arrow keys, we can't get from song to song etc.

So, either clicking on service manager item or using arrows now had the following results.

From . . . . . . . . . To . . . . 
Blank                 First song          Sends to live
Song                  Next song         Doesn't send live
Song                  Custom slide     Doesn't send live
Song                  Image               Doesn't send live
Song                  Bible                Doesn't send live
Image                Image               Doesn't send live
Image                Custom slide     Doesn't send live
Image                Song                 Doesn't send live
Image                Bible                 Doesn't send to live
Anything            PowerPoint        Sends to live
Anything            Video                 Sends to live
PowerPoint         Anything            Sends to live
Video                 Anything            Sends to live

This is a brilliant product and there's lot's i the upgrade we like.

Any suggestions gratefully received.


  • Double clicking on an item in the service manager sends it to live.

    Double clicking on an item in Library/Media Manager sends it to preview

    There are other settings in the Advanced settings to change the single click behaviour.

    The arrow keys work fine for me - I wonder whether your shortcuts have been reset? There is also a setting in Advanced settings that allows you to use the next/previous to go from one item to another.

    You need to make sure that the Live window has the focus for the keys to work. If the Service window still has focus then the arrow keys will just move the selection within the service window.

    Hope this helps,

  • I have just experienced the same problem - with the previous version you double clicked on the first item and then the arrow keys worked fine between verses of songs and between items in the service.
    Now the left/right arrow change the item displayed in the live window but the projected image (second screen) does not change to the new item until either you blank/unblank or you change verses on the new item.
    I repeat the live window on the computer is doing what it should do, it is the projected version which does not change service items.
    Is this a bug, is there an easy fix?
    How hard is it to go back from to the earlier version?
  • @Brentwood, that issue should be fixed in OpenLP 2.4. Are you by any chance using 2.3.x? What platform are you on?
  • downloaded 2.,4 on Wednesday this week. Windows 7.
  • Will check the versions when I am at Church today to be sure (problem is that there is no internet there except when I use my phone as a hotspot).
  • Checked - Windows 7 and OpenLP 2.4

    Did a bit of playing - typical service has one custom slide, a number of songs and then 2 custom slides at the end.

    Displayed first slide OK, used right arrow, on computer it changed to first song but not on the projected second screen. Continued to go through the items and when I got to the last custom slide it displayed. Repeated the test going backwards with same result - no change on the projected screen until I got to the first custom slide.

    Tried inserting a powerpoint in the middle. Went to the song before and displayed it, right arrow took me to the Powerpoint which displayed. (A change from the last version and not sure whether this is a setting I can change, the right arrow and down arrow both took me through the slides and after the last one I got an "end of slide show" on desktop and had to hit right again. I am sure the previous version the up and down controlled the slides and right arrow took me to the next item in the service, but could be wrong). Anyway after keeping pressing right the first song after the powerpoint displayed on the projected screen.

    Hope that helps to nail down the problem.
  • @PaulR No, that's not much help, it's just describing what should happen.  What I'd like to solve is why it isn't doing what it should. Nothing has been reset. Apart from that, as I described in my original post, videos and PowerPoint are unaffected.

    Symptoms seem to be same as @Brentwood which would confirm that there is some bug on the upgrade.
  • We can cope for a short while because we normally blank between items, however sometimes we have a sequence of items without blanking which will be a pain.
    I also like to run through the whole service beforehand to check I have got it all in the right order and that it displays correctly so that is an annoyance.
    If a fix were possible then I would be most grateful because it is an aexceelent product in all other ways.
  • @Gracechurch sorry it wasn't any help, I made the assumption that as it works as documented for me, it might be something as simple as clicking vs double-clicking etc.
    I have OpenLP V2.4, Windows 10, Office 2016, a secondary display, and I can't reproduce what you are seeing. I've tried with services containing custom slides, songs, images, powerpoint presentations.
  • Hi,
    If this issue is the same as we (tried to) fix in 2.4, then you should be able to work around it by going into the OpenLP settings, in the Player section, and disable VLC and System player. Feel free to enable the webkit player.
    This should fix the problem with the slides not updating - if it is the same issue we've been battling earlier.
    The problem is that it leaves you with the webkit player as the only player, and unfortunately its media support isn't that good...
    Anyway, I hope this helps.
  • Disabled VLC on my way home and it does seem to cure the problem. Only checked custom slides and songs - will try and check powerpoint behaviour in the next couple of days.


  • Sorry @PaulR, didn't mean to chop you off at the knees there bro! Just thought that, typed it! I appreciate you were trying to help.

    @tgc have disabled VLC and this and it has cured the problem, but as you correctly point out, this takes us back to an original problem with the media player two or three versions ago which is why we downloaded VLC player.  However, in the grand scheme of things, we can live without media in favour of transitions.

    I appreciate the help from you all, particularly the guys who are authoring this and making it available.
  • I am seeing this problem only with Custom Slides where it's necessary to click Blank Screen on and off to get them to display. I also only see this in the Windows version. In Linux, where I'm executing the source code directly, the problem does not occur.

  • Symptoms and solution confirmed here too, Windows 10 OpenLP 2.4 THankfully I have everything as AVI or WMV so Webkit likes it..

  • I can confirm having the same issue with OpenLP 2.4 and Windows 10 Pro 64-bit. No problem with the 2.2 version. Thanks for the suggested Workaround, not sure it will work for us in our case though due to our media file types.

    Also, thanks for providing this amazing software. It has really helped our small church. Previously, we were just mirroring the windows desktop when using our screen to play media and show powerpoints. We use the screen a lot more now and are able to provide a seemless, less tacky, service without the congregation playing "follow the mouse pointer".
  • Hi @tgc and team, I realise this is an old post, but I'm having this same trouble. I'm running Windows 10, with OpenLP 2.9.4. I'm not using custom slides, and the workaround mentioned above (disable VLC) no longer seems to apply, it looks like the option has now been removed?

    Similar to the first post above, when I have the Live tab selected, using the right or left arrow keys seems to have irregular behaviour. For the first couple of key presses, Open LP changes to the next service item, but then the behaviour is almost random - select a previous service item, do nothing, select the next verse of the song, and so on.

    As a workaround, if I double-click on a service item (with "double-click to send live" enabled), the behaviour is similarly random. In fact, I have to double-click three times to get the item to go live. I have tried using the right-click menu to send to live and similarly, need to do that three times to get the item to go live.

    After reading this post I tried going to Blank, then changing service item, and then going back to Live, and that displays the correct slide, but that still involves a lot of clicking and dashing across the screen. Is there a better workaround?

    This issue has only started to occur when we got a new PC at church, even though it is using the same OpenLP version as my home laptop (where I create the services). Are you able to advise at all?

  • @Brentwood @Gracechurch are you no longer finding these issues with the recent upgrades to OpenLP? I haven't heard back from @tgc and am still having the same issue ????

  • We've seen a similar issue, but only when people are hitting the down button multiple times within a second. We added some code to essentially slow the input down a bit, and haven't heard about anything like this for a while. Since you said it only happens on one computer and not another, I wonder if you don't have something else installed on the computer that is actually causing the issue?

  • Thanks Raoul, appreciate the reply. The computer we use for display has literally nothing else on it apart from a browser - it is solely used for Open LP.

    Should that fix address multiple mouse clicks in the same way it addressed multiple down arrow presses? The issue we were finding is that we needed to double-click three times to get the right service item to display. In addition, using the right arrow key didn't always leap to the right service item either :(

    Thanks a bunch though! Any other help or workarounds you might advise would be much appreciated ????

    In the meantime I have downgraded several versions and this problem isn't happening anymore, it's another issue I have to deal with now. ????

  • I don't how what's going on with your computer... that's very weird behaviour. I've not experienced it at all (apart from the first one I mentioned, which I cannot reproduce in the latest version of the code I have locally).

Sign In or Register to comment.