OpenLP not able to use internet

I can't use the Web download button to get the ESV bible verses.

I press import bible and then click web download in the combo box and then download and I get this error

I have allowed OpenLP in my firewall.

Still no good. I have even run the program as an administrator!

I have no idea what to do to fix this. The wireless connection works great.

After it gives the internet connection error it tries to load from 0% to 100% and once it reaches 100% it gives this error:

**OpenLP Bug Report**
Version: {'full': '2.2.1', 'build': None, 'version': '2.2.1'}

--- Details of the Exception. ---

I tried to download bible list from import bible

 --- Exception Traceback ---
Traceback (most recent call last):
  File "D:\OpenLP_Development\OpenLP_Code\2.2\openlp\plugins\bibles\forms\", line 528, in on_web_update_button_clicked
  File "D:\OpenLP_Development\OpenLP_Code\2.2\openlp\plugins\bibles\forms\", line 458, in on_web_source_combo_box_index_changed
KeyError: 0

--- System information ---
Platform: Windows-10.0.10586

--- Library Versions ---
Python: 3.3.2
Qt4: 4.8.5
Phonon: 4.4.0
PyQt4: 4.10.3
QtWebkit: 534.34
SQLAlchemy: 0.9.4
SQLAlchemy Migrate: -
BeautifulSoup: 4.3.2
lxml: 3.2.3
Chardet: 2.2.1
PyEnchant: 1.6.6
Mako: 1.0.0
pyICU: 1.5
pyUNO bridge: -
VLC: -

Please help and let me know if you need any other information!



Sign In or Register to comment.