icons and text too small on hi-res display


recently I got a new Dell laptop (Latitude 7370), it has a native display resolution of 3200 x 1800
running Windows 10. When using OpenLP 2.4.2, all the icons and much of the text is way too 
small on that display. It seems OpenLP does not honour the Windows setting that makes programs
scale icons and text to compensate for the high display resolution.

Is there any way this could be fixed? Modern mobile equipment will almost certainly have hi-res

Thank you and best regards,


  • If I recall correctly (from conversation, I don't use Windows), there's a setting you need to look into on Windows which will fix this. I'm afraid I can't remember the name of the setting, but it's something to do with screen resolution.
  • unfortunately both suggestions do not work: 1) openlp is not aware it should scale its display
    and 2) the noteboox in question has such a high resolution (3200x1800) that one can't live with the
    "disable scaling" setting also, the icons are way too small.

    I know this might require some coding effort, but since high-res displays might become common
    soon, I hope this can be fixed.

    Thanks, Rainer
  • edited August 2016
    Hi rainerle, 

    Thank you for your feedback,
    we have recently started working on improving our icons.
    Font sizes is something we are discussing about.

    Part of the problem is that your screen is only 13' inches and uses
    the resolution of 3200*1800. this gives you the pixel density of 260 PPI.

    Normally the PPI in computer screens is around 90 PPI.
    (For an example 24' screen with 1920*1080 resolution)

    Because all the pixels need to fit the 13 inch screen everything is very small.

    For now all you can do is to try and increase the font sizes further.
    Did you set the scaling via Control Panel\Appearance and Personalisation\Display?
    Microsoft actually recommends setting the text sizes manually.

    Hope this is helpful and sorry for the inconvience,

  • Hi Azaziah,

    yes, the pixels on that screen are incredibly small. I tried to change those settings in control panel, but the
    openlp icons remain very small, see the image. Text size is already at 200%

    Best, Rainer

  • Try changing font sizes from:

    Control Panel > Appearance and Personalisation > Display > Make text and other items larger or smaller

    instead of the overall scaling %, this may has better results.

    Alternatively you could lower the resolution of your display.


  • There is an interesting article here  by a Microsoft engineer talking about what they are doing to try to address this issue.
  • I have the same problem on Surface Pro 4. I observe on the screenshot from the original poster and my experience that the text size is actually okay, but the icons are particularly small and not to scale with the text. This indicates that it is not related to Windows in-built font scaling. This also seems particular to OpenLP as applications on the same PC do not have problems with icon size.

    Perhaps Qt under Windows has its own settings for scaling (just a guess as I don't know much about Qt!).

  • A patch fix would just to be to increase your resolution on your screen, I have the same problem and was only able to increase font size, icons didn't budge. I recommend 1920x1080 or something close to that.
  • We are aware that the icons are really small on high resolution displays, and we are working on a potential fix.
  • So this was three years ago and today I installed it on my Lenovo ThinkPad X1 tablet and you still haven't dealt with this. All other apps / programs I've ever used are absolutely fine... except OpenLP.

    I've adjusted scaling and it makes zero difference. The icons are miniscule.

    When are you going to address this?

  • bump bump bump... there's really no point in us committing to an open source program if there's not even a forum response to these issues. We don't expect everything to be fixed all at once. But if the powers that be aren't even acknowledging issues on the forum and giving the community some kind of feedback, you start to undermine people's trust in your product.
  • @whatever Sorry your frustrated by the lack of progress.  We accept that 3 years is a long time between revisions of the program and resolution to the issues.  I can only say that the development team is aware of the issue.  Fixing anything on revision 2.4.6 has taken a complete ground up re-development.  This has been no small task for a group of volunteers. 
  • There ist a workaround which should work with all programs on Windows:
    In Explorer or on the Start menu, right-click the application name, select Properties, select the Compatibility tab, select edit high DPI-settings (or something like that, i have german Windows), and then at bottom set override high DPI-scaling, set the checkbox and select System for Scaling. Now everything should scale with your Systemsettings, but the icons might be blurred.
Sign In or Register to comment.