openLP using LibreOffice shows PPT slides on wrong screen

Operating system
Windows 7
I've just done a new install on a new machine to try and resolve this issue and still have the same problem:

OpenLP using Libreoffice (5.2.2) to run PPT or ODP slides (no powerpoint or powerpoint viewer installed).

Extended desktop all appears fine for OpenLP song use, BUT when I set the PPT running the two displays are wrong way round. I get the slides on local monitor and presentation manager on projector.

Here's what I've done to try and fix this, without success so far:

Open up libreoffice and ensure the correct output display is selected (Display 1). Test the PPT from within libreoffice. OK.
When running again from OpenLP same error. Then when i go back to libreoffice I find Display 2 is now (wrongly) set; OpenLP (I think) is forcing libreoffice to change this setting each time it tries to play the PPT. Every time I reset it within libreoffice if i play it with OpenLP it resets it to wrong display.

I have toggled on and off:
'Bypass X11 Windows manager'
'Allow presentation application to be overridden'

and within libreoffice toggled on/off the 'presentation manager'

and tested all combinations of the above three(!) makes no difference.

'Identify displays' (on this desktop Nvidia card) shows: HDMI O/P is the projector, as 'Display 1'; DVI O/P is the users' monitor as 'Display 2'. I have ensured display 2 is set as the Windows 'Main Display'

I guess if I got some DVI to HDMI cables I could switch the display cards' outputs to be inverted??
Can OpenLP only get the presentation working right now if the projector is recognised by the hardware as 'Display 2'?? This feels like what's happening.

This used to work fine before newer versions of OpenLP with the same hardware (or perhaps it's libreoffice!)

THANKS for any help - and this excellent piece of software!



Comments

  • edited October 2016
    My guess, from what you've described, is that Windows is incorrectly reporting to OpenLP which display is the primary. You said that your second monitor is the main or primary display, but Windows is telling OpenLP that your first monitor (the projector) is the primary display. Go into OpenLP's settings and see which screen is detected as the primary screen.

    Also, "Bypass X11 Window Manager" is a Linux setting, it does nothing on Windows ("window", not "Windows").

    Also please note that OpenLP 2.4.3 is out, and I highly recommend you upgrade.
  • This is actually a known issue, though not reported that often: https://bugs.launchpad.net/openlp/+bug/1564924

  • edited October 2016
    tgc that's the same issue, thanks for flagging. Impress is wrongly numbering the screens.

    My workaraound at present is to set the external (projector) monitor as Windows' 'primary display' and by doing so I can make OpenLP run impress slides in the same screen as OpenLP uses. The only issue with this is that many programs and windows as they open default to the 'primary display'. Some when they are dragged to the secondary screen will remember their previous position whence they opened!

    it's not really an answer. I'm gonna try an older version of Libreoffice and see is that helps.

    MS PowerPoint viewer wasn't much help as this also default displayed to the 'primary monitor' and didn't send to the same one that OpenLP specified, even when OpenLP was 'controlling' it (although it worked OK as Impress did when using my 'workaround'). I assume this is not normal as there would be no point in using PowerPoint viewer if so?

    I might try a different video card!
  • I was really tearing my hair out on this - not got much left anyway! Nb. this is not a laptop it's a desktop PC setup. I changed from nvidia graphics card to an ATI one and that resulted in no difference. Then I remembered that in a previous configuration I had used a VGA output for the local (operators) monitor. In my recent setup, with all the above problems, I was using the HDMI and DVI outputs. Changing the DVI o/p for the VGA o/p for the local monitor results in the slides (both in Impress and ppt viewer) displaying on the projector o/p. Yay! Be worth knowing why though - no ppt/odp from within OpenLP was nearly a deal breaker!
  • Sounds like a bug in LibreOffice then. Certainly if OpenLP is operating fine for songs and Bible verses.
  • I guess it is arguably a LibreOffice thing, BUT there's definitely some OpenLP influence of what's happening with Impress because if you run the show in Impress (not using OpenLP to do so) you can set the correct display (albeit that the display numbers don't tally with DisplayPropreties as previously mentioned) and all runs fine.

    Next time you try and run the ppt via OpenLP it displays on the wrong screen and when you look at LibreOffice 'slide show/slide show settings' you find that OpenLP has changed the selected display to the wrong one. Correcting it in Impress and trying again in OpenLP always results in it changing back to the wrong display. Surely OpenLP need not make that change? Nb. this is only happening when using DVI/HDMI displays as the two outputs. VGA and one of the digital OPs doesn't replicate this issue.
  • Well, OpenLP tells LibreOffice which screen to use, based on the screens it gets from Windows. So OpenLP is seeing that the secondary screen is screen "2", and it shows the songs on screen "2", and then tells LibreOffice, "show yourself on screen 2" and LibreOffice shows itself on screen "1". You tell me where the bug is.
Sign In or Register to comment.