MINIX NEO Z83-4

Operating system
Windows 10
Hello Everyone,

Being a developer, and too curious by nature, I volunteered myself into improving my church's AV setup. Really blessed to find OpenLP. Gave it a try the other night, and was very impressed! Not just by the quality of product, but also the general setup and workflow. Great work!

To business...

The church's current machine is XP. Time for something new. Is the MINIX NEO Z83-4 too underpowered? I read the minimum requirements, but 2Ghz is pretty general. 2Ghz of a sixth gen. Core isn't the same as 2Ghz of a P4. I think I get why the specs are so general, this doesn't seem like a terribly demanding app. But, before I go purchase something, I'd like some comments by people who have more experience with the app.

This machine is passively cooled, has AC WiFi and 1gbps ethernet. Two display ports, one HDMI and one mini-DP (though, it doesn't support DP --> HDMI. Have to go DP --> VGA, but that's OK for the monitor). 4GB of RAM. It has a x5-Z8300 CPU. I can split the TRRS headphone jack for stereo output and mono in (good enough to record sermons). One USB3 for an external 4TB HD that they'll never fill, one USB2 for a webcam to stream the service on YouTube Live, two USB2s for keyboard and mouse.

I know it is very likely nobody else has tried this particular model, and perhaps even this particular CPU. I know the only way to know is try it and see. But, I'm hoping somebody has some experience pushing the minimum requirements. A number of the posts I found were about older machines, that were probably middle of the road when they came out. I'm wanting to know about modern low-end setups.

Thanks,
Stephen

Comments

  • Hey Stephen,

    That machine looks like it would work fine. I have used OpenLP on a Mac Mini which has 4GB RAM and an older model dual core i5. I'm pretty sure that MINIX will pack more of a punch.
  • Hi Stephen
    If you do give it a try, please post back with your experience, it looks like a good low cost space saving option.

    We're still running OpenLP 2.2 on a mid-range Dell Laptop I bought back in June 2007 and it still runs fine, so I would hope that hardware 9 1/2 years newer would also run it fine.
  • edited January 10
    OpenLP really isn't that demanding.

    I think the real bottleneck for church AV system would be
    the lack of horsepower to run full HD videos, but pretty much
    all of today's computers can run them.

    The item description for MINIX NEO Z83-4  includes:
    • "Multi-Purpose PC – Excellent Thin Client Solution or Home Theater PC. Equipped with Dual Output display ports (Mini DP and HDMI) and supports up to 4K @ 30fps."
    so you should even be able to blast in 4K videos if need be,
    thou they are still relatively rare in church services.
  • Thanks, everyone! I bought it, so we'll see how it goes. I'll report back on my findings and thoughts. If worst comes to worst, I'll just keep it as a new media machine and get the church something else.
  • Hi Everyone,

    Today was the first time we used the Minix and OpenLP for a service. It seemed to work really well! Here are a few scattered observations:
    • The Minix is surprisingly responsive. It doesn't come with any bloatware, and it seems to be pretty stable.
    • AirServer seems to work well for iOS mirroring. I haven't had an opportunity to try Miracast and Chromecast yet.
    • The Minix can support two HDMI connections, with an ACTIVE mini-DisplayPort to HDMI adapter. That's what we're currently using, to eventually get to DVI on the projector.
    • OpenLP connects to our projector (yay!), and will turn it off and on. However, it won't do input select for some reason - it throws an error. Please, someone let me know who/where I should send additional information.
    • Transitions seem to be a bit glitchy. However, I don't think that's because of the Minix. I see the exact same behavior on my three year old retina MacBook Pro. But... not a big deal.
    • Today, I taught someone else how to enter songs. They did so, but couldn't get slide splits to work. So, I went back to the computer thinking it would be really simple - as I've used it on a number of songs and custom slides without issue. But, I couldn't get it to work either. I checked for any hidden characters, deleted and re-added the verse, took the text through Notepad to ensure there was no odd formatting issues. I couldn't get it to work. In the end we made two Verse 1 slides, and fortunately OpenLP was smart enough to treat them as one in the slide order. But, someone let me know if you want more info. I'm not sure how to provide much, though. There was no error, nor any indication that the split existed outside the editor. Really weird.
    • The iOS app has worked great for me. I left a review, trying to counteract the effects of the two reviewers that didn't know how to set things up.
    • The person running the system today used Android, also worked well.
    • Lastly, is it just me, or is there no "Show" button in the main interface? If I blank the screen, I have to use a phone app to get it back to show. I can't find that button on the desktop UI.
    Anyway, I'd recommend the Minix - if you are well aware of its limitations. It's well made, power efficient, fairly feature-packed, cheap, and small enough to mount behind a monitor (there are 3D printable VESA brackets, from what I hear). It loads OpenLP slower than my rMBP does, but other than that the experience is pretty similar.
  • Hello thestevo -

    As far as the projector goes, if you can start OpenLP with logging set to debug, then post the log as an attachment here, I can have a look and see what's up.

    The easiest way to start debug mode is from command line - 'openlp -l debug'

    In linux, the log file is saved as '~/.openlp/openlp.log' - (the tilde charachter ~ indicates the home directory of who is logged in when OpenLP is run). Also, note the period as part of openlp - '<tilde><forward slash><dot>openlp<forward slash>openlp.log'

  • thestevo - Also, while you're logging, could you exercise all of the options from power on to the other projector control options, to power off? Thanks
  • Also - could you post the information about your projector? make, model, type, etc. A link to the manufacturer page on that particular projector would also be helpful.
  • I installed 2.4.5 yesterday, as I needed to change over from using the portable version to a full install. When I did, that seemed to fix the projector issue. So, maybe it was just an issue with the portable version? 2.4.5 release notes don't speak of projector fixes.

    I'll be keeping an eye out to see if that issue with slide splits shows up again.

    And, I still don't see a "show" button in the UI. We're having to using the phone app to get the display back if it is has been blanked.
  • @thestevo To return from "black screen" simply push the button again!?
  • Oh, it's like a toggle? Sorry, I didn't think to try that. I would suggest at least a user option for a "Show" button, as I didn't find that to be very discoverable. 

    I'll give that a try on Sunday.
  • Maybe it's not that clear on Windows? On Linux/KDE and macOS, the button is very clearly depressed.
  • Hi Raoul,

    Yes, it is visibly depressed, but I interpreted it like a radio button - where you must select one of the given options. I didn't know you could click it again to toggle out. I tried that today, and it did work fine. Not a big deal - it works perfectly - I'm just adding feedback that it wasn't very intuitive or discoverable for me.

    I guess part of it was that I first tried that feature via the iOS app, where all options (including show) are side by side. So, when I got to the desktop and saw all options except show, I was coming to the interface with the wrong expectations.

    Thanks,
    Stephen
  • edited February 21
    @raoul - It is interesting how the different GUI behavior led @thestevo astray. I would like to see the GUI choice from the iOS app and Web remote in the Android app and Desktop version, too!

    Desktop: https://manual.openlp.org/creating_service.html?highlight=blank#using-the-blank-to-control
    _imagesblank_screen_dropdownpng

    Android: https://manual.openlp.org/android-remote.html
    httpsmanualopenlporg_imagesdroid_blankpng

    iOS: https://manual.openlp.org/ios-remote.html#service
    httpsmanualopenlporg_imagesios-service-screenpng

    Web Remote: https://manual.openlp.org/web_remote.html
    _imagesweb_remote_slide1png


Sign In or Register to comment.