Bug during importing Indonesian Bible

Operating system
Windows 7
Hi Everyone, 

I've tried to import Indonesian Bible (TB) to OpenLP, however, I encountered a bug when I'm trying to installed it. Could you tell me how to fix the bug, please? 
my Bible file is in .csv format. Thanks in advance

Comments

  • You have to tell us what the bug is...
    See this for the required format: http://api.openlp.io/api/openlp/plugins/bibles/lib/csvbible.html

  • Hi tgc, 

    I've solved the problem. I just downloaded Bible from OpenSong and it works. Thanks.
  • Hi arierichie,

    Could you please share the indo bible from OpenSong with me? Because the file is no longer available there.

    Many Thanks
  • @arierichie, if you no longer have the import file, you could also share the .sqlite Bible file (on Windows, it's typically located in %AppData%\openlp\data\bibles\).

    It looks like the file was originally hosted at DropBox, but has since gone missing.
  • Hi @milon

    I managed to get the bible file in .sqlite3 format, and I've placed it in %AppData%\openlp\data\bibles\
    But still it doesn't show up in the bible version list in the OpenLP app.
    Is there another step I should do?

    Thanks
  • I posted earlier without testing, sorry.  It's likely that a config file lists which Bibles OpenLP has registered and expects to find in that folder.  I'll try to look at that later today and tell you what I find.  In case you're handy/brave, and can get to it before I do, I plan to look through the config files, see which one records OpenLP's known Bibles, and duplicate an entry for the new Bible.
  • Hi @milon

    Yes that's exactly what I was thinking too. But couldn't find the config file that reference to those sqlite bible files.

  • @playmaker_edition, sorry for the delay.  My schedule changed unexpectedly.

    Anyway, I looked into it.  I couldn't find a config file either, so I tried just dropping in an .sqlite Bible file, and it worked like a charm.  Things to note:
    1. OpenLP must not be running for this to work
    2. OpenLP writes numerous settings on exit - it's best to wait for the openlp,.exe process to close before copying in the new .sqlite file
    3. If that doesn't work, copy the file in then restart the PC, and THEN run OpenLP

    Let me know how it goes.
  • Hi @milon

    I've followed all your advice, but still no luck for me.
    I attached the bible file, maybe if you want to try from your machine.
    By the way, the bible file that I have is in sqlite3 format instead of sqlite. Would it make any difference?

    Thanks anyway for responding my question though.
    I just wished that someone can share the opensong indo bible file. It's really a shame that the file in their website is no longer available.
  • I've never been able to find forum attachments here. :(

    Try renaming it to end in .sqlite and try again. If that doesn't work, email it to me and I'll see what I can do. My email (or anyone's) can be found by clicking on my user profile name. You'll see it listed near the top of the profile page.
  • I've changed the way the forum does uploads. Use the "Attach a file" link to upload a file. The previous system worked, but you had to drag and drop the file into the editor box after uploading in order for it to show up in the post (unintuitive, I know).
  • Hi @milon

    I did try to rename it to end with sqlite format then pasted it into the folder, then when opening the OpenLP, it reported an error which related to that bible file.

    I couldn't find your email address in your user profile page though.

    Anyway, I'll re-attach the file again here using the "Attach a file" link as advised by @raoul. Thanks for helping out.

    Many Thanks!
    zip
    zip
    bibledata-id-tb.zip
    4M
  • Also, I had a look at the .sqlite3 file you attached (thanks!), and it looks like it's structured correctly, but the content parts are full of formatting tags which OpenLP doesn't use.  Seems like it's entirely incompatible - without a lot of work to remove the extra formatting.

    But hey, I think you'll find the solution in your email, so it's a moot point!
Sign In or Register to comment.