remote control isn´t working with windows 10

Hi
we are using version 2.4.6 on windows 10.

since we upgraded from win7 to win10, the remote control plug-in stoped working.

it feels like we have tryed everything, but can´t figure out why it´s not working.

any ides?

Comments

  • Could you be more descriptive about the problem?  Is the plug-in unavailable?  Does it crash?  Does the remote fail to connect?  Does the remote viewer crash?  Some other problem?
  • Are you using the web remote, the Android remote or the iOS remote?
  • I had the same problem, tweaking the firewall settings on the church computer solved it.
  • Hkonsig, can you explain for me how to do that. We have tried but hasn´t benne sure what to do.


    to descibe the problem more? well. the plug-in is activated, and every thing work just fine on Win8 BUT when we change to Win10, Nothing with the remote plug-in work.
    the webbrowser says that there is no page to be open.
    The andriod remote app can´t find a server.

    so basicly i can´t connect to openLP. either it´s not sending anything or the firewall blocks it.
    even if i try to connect to the web remote on the same computer as a use as transmitter I can´t connect
  • edited June 2017
    I apologize for my late answer to your post.
    Search your computer for "Advanced Firewall settings", check that Openlp.exe is allowed to connect to outside connections. It may be several instances, allow them all.
  • Hi everyone,

    Since this is my first post in this forums I would like to start with thanking you for putting all the effort into this awesome software! We use it a lot in our church :)

    So, we had a problem like this in our church, ie. we could not use the remote controller. At first I thought it was a problem with firewall settings, but OpenLP didn't even seemed to be bound to a port (didn't show up in netstat /a /b). It turned out to be caused by the name of the computer. It contained non-english characters (it was 'Vetítő'). Checking the name of your computer should be worth a try.

    If OpenLP shows up when running "netstat /a /b" in a command prompt, then you have some different problem.

    God bless you all,
    Laszlo
  • Hi
    A old post I see and didn't know if it is solved. I had a problem like that and it was a problem with public and private network. Check if your network is private and not public. 
    Hope it can help someone. 
    God bless you all
    Threep
  • I know this is an old thread but I’ve got the same problem. Should I start a new thread with the same question?
  • Between changing the IP address and adding an OpenLP remote port rule to Windows Firewall it suddenly began working!
  • @SCFC ; Here is good. 
    Are you on Windows 10 running OpenLP 2.4.6? 
    Are you using the Android, Apple or web based remote?

    you can start to help us troubleshoot the issue while you answer the above questions....
    1. Start OpenLP and double click the first item in the Service.  This should start the display of Service item.
    2. Press the `ESC` key to stop the presentation.
    3. Open Settings --> Configure OpenLP --> Remote
    4. Click on the Remote URL.  A browser window should open and display a web based control page.  Doing this on the same device that is actually doing the projection shows that the application is functioning as expected.
    5. On any other device on the same network as the projection device, open a browser and type in the same URL.  The web based control page should be displayed.  if the control page is displayed this shows the firewall is setup correctly.
    6. On the Android or Apple remote app, configure the remote IP address using the numbers from the URL for the web based control page.  Once the app has been configured you should be able to interact with the OpenLP app and control it.  If you are still having issues, try turning of your Cellular Data....this forces the data to be routed through the Wifi connection and with any luck it will be the same network as the device running the presentation.
  • @JohnM. Hi I'm just starting to learn OpenLP and the remote control seems like the killer app for me, but so far it doesn't work. I used your steps above and got stuck on 4. I don't get any response in the browser on the same computer. 
    This is Windows 10, and Chrome browser. 
    Where do I go from here? Could it be firewall issues even on the same PC?
  • @sverker please verify the Remote plugin is active.  The Manual has a page to explain how to check your plugins to make sure they are active...Be sure the Remote plugin is active.
  • Yes the remote plugin is active. When I click on the remote control link I get ERR_CONNECTION_REFUSED. I also tried with localhost:4316, but same result.
  • I can't find OpenLP in the list of running services on my PC. I assume that the remote plugin starts a web server, and this webserver should belisted in Services, shouldn't it? If there's no web server it is expected that I can't find the web page. So how do I kick the server alive?

  • @sverker ; I have not had this issue myself, but here are two things you can try and see if they help....

    1. Disable the remote plugin, restart OpenLP and enable the remote plugin then try to access the remote screens or control screen by double clicking on the link(s) in Settings under the Remote.  If by chance toggling the plugin allows you to see the screens on the same PC, then try to view them on a different device.
    2. Disable your firewall.....try to access the remote screens or the control screen by double clicking on the link(s) in Settings under the Remote.  Enable your firewall!!!!  If the firewall is causing the issue, you should be able to access the screens while the firewall is down and not after you re-enable the firewall.
    Let us know how this goes.
  • @sverker if the above doesn't help, start at the top of this discussion....there are more than one suggestion that might help.
  • @JohnM Hi John (and others). I have tried the above. I have also tried disabling the various firewalls and I have expressly allowed openLP to pass through the firewall. I also tried netstat as suggested higher up, and can't see openLP there. 
    Nothing works so far. I don't get any warnings from the firewall or antivirus. OpenLP itself seems to work allright. 
    Do I have to have OpenLP in Live mode to use the remote? In this setup I only have one screen and in Live mode openLP doesn't allow me to use anything else than openLP. But I tried remote and that didn't work anyway. 
    Any more suggestions?
    Should I try version 3?

  • @sverker The remote functions were not working in the Alpha that was released for testing....I would not suggest trying it for this issue.
    Your running in single screen mode....There is a way to reduce the size of the "live" screen and it is useful for testing the remote operation.  The manual has a section about configuring the display.  Myself I use a display size of about 1/5 the size as my laptop display and I leave the start values at 0.  I also move my OpenLP main window to the bottom right corner so with the "Live" screen active I can still get to the main window.

    I have only used the remote screens when I have a service loaded and I have double clicked on the first Item in the service...See if any of this helps.
Sign In or Register to comment.