remote control isn´t working with windows 10

Hi
we are using version 2.4.6 on windows 10.

since we upgraded from win7 to win10, the remote control plug-in stoped working.

it feels like we have tryed everything, but can´t figure out why it´s not working.

any ides?

Comments

  • Could you be more descriptive about the problem?  Is the plug-in unavailable?  Does it crash?  Does the remote fail to connect?  Does the remote viewer crash?  Some other problem?
  • Are you using the web remote, the Android remote or the iOS remote?
  • I had the same problem, tweaking the firewall settings on the church computer solved it.
  • Hkonsig, can you explain for me how to do that. We have tried but hasn´t benne sure what to do.


    to descibe the problem more? well. the plug-in is activated, and every thing work just fine on Win8 BUT when we change to Win10, Nothing with the remote plug-in work.
    the webbrowser says that there is no page to be open.
    The andriod remote app can´t find a server.

    so basicly i can´t connect to openLP. either it´s not sending anything or the firewall blocks it.
    even if i try to connect to the web remote on the same computer as a use as transmitter I can´t connect
  • edited June 2017
    I apologize for my late answer to your post.
    Search your computer for "Advanced Firewall settings", check that Openlp.exe is allowed to connect to outside connections. It may be several instances, allow them all.
  • Hi everyone,

    Since this is my first post in this forums I would like to start with thanking you for putting all the effort into this awesome software! We use it a lot in our church :)

    So, we had a problem like this in our church, ie. we could not use the remote controller. At first I thought it was a problem with firewall settings, but OpenLP didn't even seemed to be bound to a port (didn't show up in netstat /a /b). It turned out to be caused by the name of the computer. It contained non-english characters (it was 'Vetítő'). Checking the name of your computer should be worth a try.

    If OpenLP shows up when running "netstat /a /b" in a command prompt, then you have some different problem.

    God bless you all,
    Laszlo
  • Hi
    A old post I see and didn't know if it is solved. I had a problem like that and it was a problem with public and private network. Check if your network is private and not public. 
    Hope it can help someone. 
    God bless you all
    Threep
  • I know this is an old thread but I’ve got the same problem. Should I start a new thread with the same question?
  • Between changing the IP address and adding an OpenLP remote port rule to Windows Firewall it suddenly began working!
  • @SCFC ; Here is good. 
    Are you on Windows 10 running OpenLP 2.4.6? 
    Are you using the Android, Apple or web based remote?

    you can start to help us troubleshoot the issue while you answer the above questions....
    1. Start OpenLP and double click the first item in the Service.  This should start the display of Service item.
    2. Press the `ESC` key to stop the presentation.
    3. Open Settings --> Configure OpenLP --> Remote
    4. Click on the Remote URL.  A browser window should open and display a web based control page.  Doing this on the same device that is actually doing the projection shows that the application is functioning as expected.
    5. On any other device on the same network as the projection device, open a browser and type in the same URL.  The web based control page should be displayed.  if the control page is displayed this shows the firewall is setup correctly.
    6. On the Android or Apple remote app, configure the remote IP address using the numbers from the URL for the web based control page.  Once the app has been configured you should be able to interact with the OpenLP app and control it.  If you are still having issues, try turning of your Cellular Data....this forces the data to be routed through the Wifi connection and with any luck it will be the same network as the device running the presentation.
Sign In or Register to comment.