If your remote does not work......

Hi there Ive just installed OpenLP on both Linux and Windows PC.
Linux was a piece of cake except for presentation problems, Windows not so; remote refused to work so I'll share with you
1..follow the instructions in OpenLP manual/remote both desktop and eg Android sections, and if it doesnt work;
many if not most, will be using wifi to remote connect. The problem will be caused by your router blocking the port that OpenLP and your remote is using.
2..Tip: within OpenLP remote setup, enter into 'serve on ip address' 0.0.0.0 then below your ipconfig value should be shown, then enter that into your 'serve on ip address' using your browser, open your router admin panel eg if you have an Asus Wireless Router you would likely enter 192.168.1.1 in your browser address bar and make sure you know your admin passwords.  You will need to go to port forwarding and add an additional (open) port, same as showing on your OpenLP remote settings. Save this new port (forward) and go to 3 below to check.
3..check your android app has same settings as on your PC OpenLP/remote settings, close android app and reopen. You now should have a fuctioning remote control.
4..if still not working, you have entered your port forward incorrectly.

Hope this helps somebody. Remember the IP your PC works on can be found easily by using my tip above (as well as ipconfig or ifconfig)
God Bless.
Alistair.

Comments

Sign In or Register to comment.