Upgraded from 2.2 to 2.4 - Big mistake

edited August 19 in Troubleshooting
I upgraded from 2.2 to 2.4 hoping the newer version could handle an opacity image. It could not. Neither can it support it's own transparent background as in previous version of 2.2. It uses black or white despite being set to transparent and it never gets rid of the slide. Slides start posting all over themselves.

*Edit* There is a link that takes us to a blog where it is acknowledged that the transparent background is a known issue and they tell users to use 2.4. 2.4 does not work. Neither does 2.3.3. Same issues. I'm now going back to 2.3.1 to hope that solves my issues temporarily. **EDIT** 2.3.1 also cannot read the newer song database. Final try is 2.3.2..........yeah ***EDIT*** ---- still the same issue. Layering on top of itself, not capable of doing transparent. This is a joke.

I seen some posts where there seems to be a misunderstanding of what it means to have an image as a background. If the image is being used as a background, OpenLP should not be creating any other canvas (hence no forced color selection). The blank space should be treated as transparent, or the image stretched. Not having the opacity support is seriously limiting potential.

Additional information - going from 2.2 to 2.4 is a death sentence because they used two different data bases for the songs. Now I cannot revert back to 2.2 as it is incapable of reading the newer database. This is super frustrating.

Comments

  • Hi Jordan

    Please have a look at the downgrade guide in our fine manual: http://manual.openlp.org/troubleshooting.html#downgrade-guide-how-to-restore-a-backup - Let is know if this works for you.
    Just as a note, version 2.3.x was development/beta versions, not meant for production use.
Sign In or Register to comment.