OpenLP refuses to open Impress presentations (SOLVED)

GPCGPC
edited February 4 in Troubleshooting
When I try to open an Impress presentation in OpenLP it crashes. Powerpoint presentations open without problems.

**OpenLP Bug Report**
Version: {'full': '2.4.6', 'version': '2.4.6', 'build': None}

--- Details of the Exception. ---

Trying to open .odp presentation

 --- Exception Traceback ---
Traceback (most recent call last):
  File "/usr/share/openlp/openlp/core/lib/mediamanageritem.py", line 318, in on_file_click
    self.validate_and_load(files)
  File "/usr/share/openlp/openlp/core/lib/mediamanageritem.py", line 374, in validate_and_load
    self.load_list(full_list, target_group)
  File "/usr/share/openlp/openlp/plugins/presentations/lib/mediaitem.py", line 191, in load_list
    doc.load_presentation()
  File "/usr/share/openlp/openlp/plugins/presentations/lib/impresscontroller.py", line 244, in load_presentation
    self.create_thumbnails()
  File "/usr/share/openlp/openlp/plugins/presentations/lib/impresscontroller.py", line 268, in create_thumbnails
    os.makedirs(self.get_temp_folder())
  File "/usr/lib/python3.6/os.py", line 220, in makedirs
    mkdir(name, mode)
FileExistsError: [Errno 17] File exists: '/home/dvp/.local/share/openlp/presentations/Impress/Notices 10.odp'

--- System information ---
Platform: Linux-4.15.0-43-generic-x86_64-with-LinuxMint-19.1-tessa
Desktop: Xfce

--- Library Versions ---
Python: 3.6.7
Qt5: 5.9.5
PyQt5: 5.10.1
QtWebkit: 602.1
SQLAlchemy: 1.1.11
SQLAlchemy Migrate: -
BeautifulSoup: 4.6.0
lxml: 4.2.1
Chardet: 3.0.4
PyEnchant: 2.0.0
Mako: 1.0.7
pyICU: 1.9.8
pyUNO bridge: 6.1
VLC: 3.0.4
Libreoffice: 6.1.4.2 Build ID: 1:6.1.4-0ubuntu0.18.04.1~lo1


Comments

Sign In or Register to comment.