Presentation screen when primary monitor is not screen 1

I recently got an extra monitor that is 1080p (my primary, screen 4, is only 1600x900). I am mirroring the stage view TV (1) and my 2nd monitor (2) and then the presentation TV is (3)
Long story short, to get the mirroring and with the outputs available, monitor 4 is on VGA and there's no way around it.  Everything was fine until I had to change this.

In LibreOffice Impress, this is how it shows:
Display 2 is my stage view, I need Display 1 for the main presentation (screen 3).  However, in OpenLP, Display 2 is what I need:

It seems that OpenLP is setting Impress to use the same "display" as the screen is set in OpenLP settings. The difference in how the two programs determine the screen numbering (which BOTH are also off from how Windows 10 numbers them), seems to be causing an issue.

When I change Impress to use Display 1, it moves to Display 2 as soon as I try to do a presentation in OpenLP, so for now I have to run the presentation outside of OpenLP to make it work.

Does anyone know of a better work around? Is this a bug in how it determines the screen to be used when using Impress?

OpenLP 2.4.6
LibreOffice Impress 6.1.2.1

Thanks for any and all help

Comments

Sign In or Register to comment.