Bible versions error message

I think my laptop got shut down prematurely last service and got rebooted. Now when I try to show a bible-verse I get the following error-message:

Traceback (most recent call last):

File "openlp\plugins\bibles\lib\mediaitem.py", line 664, in on_quick_search_button

File "openlp\plugins\bibles\lib\manager.py", line 273, in get_verses

File "openlp\plugins\bibles\lib\http.py", line 687, in get_verses

File "openlp\plugins\bibles\lib\http.py", line 715, in get_chapter

File "openlp\plugins\bibles\lib\http.py", line 252, in get_bible_chapter

File "openlp\plugins\bibles\lib\http.py", line 765, in get_soup_for_bible_ref

UnicodeDecodeError: 'utf-8' codec can't decode byte 0xe0 in position 28343: invalid continuation byte


Do I have to reinstall the Bibleverses?

Comments

  • This error has recently come to our attention. We don't have enough details to fully debug it (which Bible, which website, what verses), but it seems to be related to a recent change in the BibleGateway website. Unfortunately we don't have a fix for this right now, but we have tested the up-coming 3.0 release, and it works in there.
  • When is 3.0 going to be released? What can we do in the interim to display bible verses?
  • Hi all
    We've just started receiving the same problem and tried to fix by reinstalling the OpenLP software or any updates but that didn't work. How long before 3.0 is released??
  • I am having the same problem. It affects NIVUK and ESVUK. I was trying o load Proverbs 14. This seemed to start happening after Windows installed an update on Thursday. Re HOPHLH's message, the shutdown/reboot could have been caused by Windows update.

    Also, when setting up on new computer, it fails to download the Bible list, with the following message:
    "There was a problem downloading your verse selection. Please check your Internet connection"
    This is nonsense, as the WiFi/Internet works fine for everything else.
    This fault has appeared on two new computers of different makes.
  • Re Phetheho's question, my temporary (I hope!) workaround is to go to the Bible Gateway site, download the required passage and then copy & paste it as New Song. Could also paste it into Impress or PP.
  • Jim, I used the same work around.
    Luke 10:25-37 had no problem and worked as expected.
    Colossians 1:1-14 generated the same error message.  (Bug reports were submitted for the verses with issues)

    Message on the Bible Gateway web site:





  • Well if this is the case, version 3.0 has to come very soon. Already got comments about why we suddenly changed Bible version lol.
  • I also have this problem trying to access any verses from NIVUK via Bible Gateway, and a similat problem trying to register a new bible from Bibleserver. I was able to successfully register and use a new bible from Crosstalk (though their range of available bibles is significantly smaller than Bible Gateway). I've submitted error reports.
  • I also had problems after a recent Windows update. Some Bible versions seemed to continue to work fine, but others didn't.  The older versions like RVR1960 (Spanish) and KJV (English) seemed to work well.  (I think I have the files installed on my computer, but can't remember.)  The other versions are online.  Things I tried seemed to work fine for some verses, but not others.  I failed to diagnose a repeatable pattern to help in problem diagnosis.  We mostly use translations from two languages which raised a problem when either didn't work.  Thanks for your work to help solve the problem!
  • edited July 19
    Same problem here.

    Running opensuse linux 15.0
    Trying to access the NIV bible online, I believe it's bible gateway, through the verses interface. Saved bibles loaded locally work fine. It's just the online NIV one we are having this on.
    Nothing has been updated or changed on the laptop. So seeing these other posts it looks like bable gateway changed something.

    self.search_results = self.plugin.manager.get_verses(bible, verse_text, book_ref_id)

    File "/usr/lib/python3.6/site-packages/openlp/plugins/bibles/lib/manager.py", line 273, in get_verses

    return self.db_cache[bible].get_verses(ref_list, show_error)

    File "/usr/lib/python3.6/site-packages/openlp/plugins/bibles/lib/http.py", line 687, in get_verses

    search_results = self.get_chapter(book, reference[1])

    File "/usr/lib/python3.6/site-packages/openlp/plugins/bibles/lib/http.py", line 715, in get_chapter

    return handler.get_bible_chapter(self.download_name, book, chapter)

    File "/usr/lib/python3.6/site-packages/openlp/plugins/bibles/lib/http.py", line 252, in get_bible_chapter

    pre_parse_regex=r'<meta name.*?/>', pre_parse_substitute='')

    File "/usr/lib/python3.6/site-packages/openlp/plugins/bibles/lib/http.py", line 765, in get_soup_for_bible_ref

    page_source = re.sub(pre_parse_regex, pre_parse_substitute, page_source.decode())

    UnicodeDecodeError: 'utf-8' codec can't decode byte 0xe0 in position 28950: invalid continuation byte



Sign In or Register to comment.