Android Remote

edited July 26 in General Support
Hi everyone, I've been trying to get the remote app working on my Android phone and have followed all the instructions to the letter, have checked we are on the same network and check the IP address multiple times and tried a few different options, but still getting the 'unable to process, check network settings'. 

We've also had an IT guy try and he couldn't figure it either - anything we might be missing?

Comments

  • A few questions.....What OS is the computer with OpenLP running?  What version of OpenLP are you running?  What version of the android app are you running?

    The following steps will help narrow down what is going wrong.  Please try the steps in order and let us know if you have any more issues.
    1. Try to access the web address from the computer you have OpenLP running on....open a browser window and type in the web address.....The Edge browser won't work....use Internet Explorer if you are on Windows.  You should see a website that has a banner that reads 'OpenLP 2.4 Remote'.  This will verify the OpenLP remote server is operating.
    2. Try to access the same web address from a separate computer on the same network as the computer running OpenLP.  Again you should see a website with the 'OpenLP 2.4 Remote' banner.  This will verify the firewall on the computer running OpenLP is configured correctly and the server is able to up and able to talk to remote computers.
    3. Try to access the same web address on the android device....Again you should see a website with the 'OpenLP 2.4 Remote' banner.  If you don't see the website, try turning off the cellular data on the android device.  If you do see the website, then go back through the setup of the android application and re-enter the server information.
  • edited July 26
    Thanks, I'm using the latest version of OpenLP (downloaded last week!) on Windows 10, the app is the 2.0 version currently available from Play store on a Huwai P20 running Android v. 9.

    So the IP address (with the port number added) brings up the remote webpage, but it doesn't work on either my phone (whilst connected to the same wifi with mobile data turned off) or my personal laptop (again connected to the same wifi).

    Turning the firewall off doesn't work either

    Thanks

    Nick


  • You are using the same OS, the same version of OpenLP and the same android version as I am.....and mine works normally....Hang in there we should be able to correct this.

    First we will retrace the steps that activate the Remote plugin...
    1. With OpenLP running, hold the Alt key and press F7.  This will open the Manage Plugins window.
    2. In the left Box in this window the available plugins are listed.
    3. If the 'Remote' plugin is listed and says '(Inactive)' after the name then select Remote in the left Box and use the drop down in the right of the screen to select 'Active' and select the OK button at the bottom of the screen.
    4.  If the 'Remote' plugin is listed and says '(Active)' after the name then select Remote in the left Box and use the drop down in the right of the screen to select 'Inactive' and select the OK button at the bottom of the screen.  When the Manage Plugins window closes, close OpenLP.  Wait for about 30 seconds and restart OpenLP.  Now go back into the Manage Plugins window and activate the Remote plugin.
    At this point retry the steps in my previous post to see if anything has changed.  And let us know if it is still not working.
  • There is a post, https://forums.openlp.org/discussion/4270/remote-app-setup#latest that has a few other items to check...one is the type of connection your computer is on.....public vs. Private....
Sign In or Register to comment.