OpenLP android app never connect to desktop program

I follow the steps on the guide and change the IP to the one on the laptop (also tried with 0.0.0.0 but is the same issue) > open the app and change it to that one (both have the same port 4316)... I tried connecting the laptop to the phone internet (since the house internet doesn't connect it) but is the same issue, never finds it and says that the problem is with the network; both laptop and phone are on the same network and still never find it.

Comments

  • Verify you have the remote plugin active in OpenLP. Go to 'Settings' then 'Manage Plugins' to see what is enabled.  Remote should be active.

    In the Android app, you need the URL that is the settings in OpenLP.

    you can also open a browser on your phone and enter the IP address without the port....it should show a web version of the control site.
  • What Operating System are you using?

    On Windows 8.1 I had to add the OpenLP Port to the Windows Firewall to allow the connection.

    Start,  Control Panel,  Windows Firewall,  Advanced Settings,  Inbound Rule,  New Rule.
    Select "Port", click Next.
    Under Specific Local Ports, enter "4316" (or whatever port you entered in the Configure OpenLP Remote page),  click Next.
    Select "Allow the connection", click Next.
    Leave all of "Domain", "Private", and "Public" selected,  click Next.
    Give your new Firewall Rule a Name,  like "OpenLP",  Click Finish.

    Try your Remote connection again.
  • @kbm Thanks for letting us know what worked!
Sign In or Register to comment.