Lock up with single display

I'm new to openlp, trying to evaluate it on my Linux Mint 19.3 laptop. If you select a song and double click to display it, it may or may not respond to the ESC key and return to the openlp window. On several occasions this doesn't happen I cannot get back to my normal windows. The only ways out are either reboot, or at least restart the session using CTRL-ALT-BKSP, or to login remotely and kill openlp. Is there a better way to get back? Switching desktops shows the switcher, but openlp display stays on screen.
If I plug in my TV as a second display, and setting display 2 avoids the problem, but is a nuisance if my wife wants to watch something else!


Comments

  • This was a reply a few days ago to another thread:

    in OpenLP settings you can disable it displaying full screen when there is only one screen. uncheck "Display if Single Screen" in general tab of preferences.
  • But I want to be able to view a full screen, and then return to do further edits...
  • Check your hot keys to see if you have one set up to blank the screen.  I'm running Windows so my process is slightly different from what Mint would use, but for a single screen, I first have to make sure OpenLP is the "active" window...for me that is Atl-Tab....then I have to make sure the Service is active...F9 to view the Service and finally ESC or D...D just toggles the live screen and is what I use the most!

    The problem as I see it is you have to get the right part of OpenLP to be active.  If the Library is active it takes what you type as just input.  If you can get the Service active or the Themes active the ESC or D keys will control the live screen.
  • It's not a blank screen - it is showing the display. I hadn't seen the hot keys, just got the display up by double clicking the song. Now that I understand more, I can't get it to hang! Thanks for the advice...
Sign In or Register to comment.