Desktop goes to full screen mode?

New user to OpenLP. Using the program on a Macbook Air. The problem I am having is once the mac screen is looking just like I want it when I select a verse or a song to preview I loose the Preview mode on my computor. The screen in the church previews as it should with the selected verse showing correctly but my Mac screen leave me no option but to use the arrows to scroll to the next verse. I have to hit the (esc) button to get back to viewing the options for different verses but then of course this preview mode is displayed on the church overhead. Not sure how to resolve this. For now we are using an old PC for the job but we would like to use one of our more updated Mac computors. ANy tips much appreciated. Thanks..........wayne

Comments

  • Check your shortcuts.  One of them will allow you to select the Service or Theme area.  When using one screen the live screen is the main screen and covers the rest of the apps on the desktop.  You should have a way to change your focus to OpenLP, then use the shortcut to make sure the Service or Theme is active....at this point the arrow keys should work...just make sure you have them enabled in settings....if you have trouble with the Left and Right arrow keys, try the Up and Down arrow keys.

    Myself, and I am running Windows not a MAC, when I am using a PC with only one screen, I go into settings and change the screen to use 2/3 of the available screen.  This way i can click on OpenLP when the live screen is displayed.  I use the 2/3 size so the screen ratio is the same and things display almost like they should.
  • Thanks John. My issue is not with the arrows working or not but the issue is when I select the verse or chorus to be displayed my entire Mac desktop screen is displaying what the overhead is seeing instead of letting me also see the different verses that I may want to select as you would normally see in the preview mode. Not sure if I am explaining the problem correctly but the Mac is not working as the PC does when it comes to selecting a verse from a song. On the pc the overhead displays just the verse you have selected and you still have the ability to see in the preview mode on the pc desktop what options you want to select next. Not so on the mac, the mac screeen becomes a view just like the overhead so its not user friendly for being able to see what options you have for your next selection. Thanks again for the help John but still not sure how to clear up issues I am seeing on the mac. ....wayne
  • @waynebergman I'm guessing that you don't have an external monitor plugged into the Mac?
  • Let me make sure I understand this....
    The PC is connected to a projector and the projector screen shows the verses at the same time as the PC main display shows OpenLP....

    The MAC is not connected to a projector?

    The MAC without a second display would be running OpenLP in single screen mode.  In this mode the MAC screen would start by showing the OpenLP main window, but would display the verses full screen when you send them to the Live screen.  The only way to see the OpenLP main window in this mode is to "Blank to Desktop"  You have been doing this with the ESC key.  You can change the size of the area the verses are displayed on in Settings, and this might be what you need to do...This works for setting things up, but may not be desirable for a small group service.

    If you have an external display connected to the MAC, try changing the settings on the MAC so the second display is not a clone of the main display.  Then you can change the settings in openLP to display the live screen only on the second monitor.

  • HI John
    I see the confusion now sorry. No, we never use both platforms at the same time. We have a PC that is working but painfuly slow and flakey so we we would like to use our faster Mac computor instead So we have been testing the mac to see if we can get it to work but the way the OpenLP program changes the display on the mac desktop when you choose a verse from a song makes it difficult to use. So just to be clear, I am only referencing the PC in comparision to the Mac when the PC is being used and then when we disconect and try the Mac. Always its only one platform at a time sending signal to the overhead. Thanks for this .......wayne 
  • @waynebergman do you have your monitors set up correctly on macOS, and then have you set OpenLP to use the correct monitor?
Sign In or Register to comment.