openlp.org 1.0.1 Bug Reports

edited November -1 in Development

Please post your bug reports about openlp.org 1.0.1 here. Remember to read up on how to submit a bug report before posting your bug.

(thanks for the correction scubes13, link is fixed)

«1

Comments

  • edited June 2008


    Bad link to bug report instructions....


    http://openlp.org/en/documentation/development/bug_reports.html


    Only bug I have is it doesn't run on Mac. :P Kidding, kidding. Thanks for all the hard work fellas!

  • edited June 2008


    I'm afraid I failed in my task as openlp.org tester... I let one slip through! Only a minor issue though, program continues happily afterwards.


    Add a song with multiple verses to OOS.

    Go live on this song and display the last verse.

    Edit the song (from within OOS), and delete the last verse, click OK.

    Get an index out of bounds dialog.

  • edited June 2008
    • When disabling "Song Information" the warning is always English - seems the translations aren't read (tried Spanish and German)
    • File->Export: The entry "Song" cannot be translated (non-existant in english.xml)
    • Having 5 .GIF images in my OOS enabling timed slides causes an error: "List index out of bounds (1)" everytime slides should cycle.
    So much for now. :)
    Keep up the good work!
    Patrick
  • edited June 2008
    I have one more, but I'm not sure if this is to be considered as a bug or wether it can be fixed or not:
    • Animated GIFs aren't animated when viewing
    Actually that was my workaround for the problem when cycling images. Now I have to think about something else... ;)
  • edited June 2008


    I'm afraid I can't duplicate this, so reporting it just in case I'm not alone!


    During the service today, for some reason the font size for the theme suddenly increased in size! We use just the one theme throughout, which we didn't change... indeed the theme panel was turned off.


    I have it set to 17% Arial (wrap long lines rather than resize) and it unexpectedly increased to about the equivalent of 20%.. however editing the theme still revealed it as 17%. Closing and restarting openlp (didn't have time to experiment!) fixed the problem and it didn't reoccur. Even went through the OOS after the service, and the problem didn't re-occur.

  • edited July 2008


    I've finally got stuck in to trying 1.0.1 and came across the following - it may be by design & not a bug at all, so bear with me.


    Our church (like many others) doesn't have MS Office, so for visiting presentations we use Powerpoint viewer so fonts & layout don't get messed up.


    For Powerpoint viewer to work, I have the dual screens set up with screen 2 as the primary screen & going to my monitor, and screen 1 (secondary) for the data projector. So Powerpoints and video go to screen 1 (secondary/projector) & life is good - under 0.994. (So Screen 1 = Secondary = Projector, Screen 2 = Primary = Local monitor).


    From my testing, it seems v1 requires the secondary screen for output. If I set up the PC so that Screen 1 = Primary = local screen, and Screen 2 = Secondary = data projector, everything works fine for OpenLP. But when I switch it around to how I need it, nothing appears despite changing the OpenLP display monitor.


    So I guess either I've made a mistake somewhere & missed something simple, or OpenLP v1 reference Primary/Secondary rather than Screen 1/Screen 2.


    Any suggestions?

  • edited July 2008


    Check and see if your situation is not caused by your BIOS settings,


    I had a similar situation setting up Power Point and found I had to make the desired screen for DATA display as the primary boot screen in BIOS.


    By this I mean, with many DELL system boards the Display Adapter is integrated into the motherboard and therefor a part of the ChipSet drivers, BIOS will allow you to (in some cases) select if you want the intergral or AGP Card adapter to be primary, I found it nessecary to select my AGP Card adapter as primary and then set it as secondary in Windows to get the silly thing to play nice.


    Bill

  • edited July 2008


    Possible, but I think the more likely cause is due to openlp.org not supporting monitor 1 as primary output. During testing of 1.0.0 we hit problems where the main console was made inoperable when the display output appeared over the top when using monitor one as output.


    Not sure whether anything can be done with openlp.org so that if the console is not on the primary screen, then the output will display on monitor 1 as expected?


    In the meanwhile I can only suggest OpenOffice or try something like http://www.mediachance.com/free/multimon.htm with PPT viewer perhaps? (Not tried it so might not be suitable)

  • edited July 2008


    I get a similar error, "List index out of bounds (-1)", every time I start up openlp.org.


     


    This happens just after the splash screen, before the main window comes up.


    It happens on Vista SP1 and on Windows XP.


     


    I get exactly the same error again under Windows XP when I double-click on a song in the left-hand songs list (or right click and choose Preview), or double-click on a song in the right-hand order of service list (or right-click and say Go-Live).  In both cases, the song does not appear in the Preview or Live window, so this is a show-stopper bug.


    Is anyone else getting this error as frequently as I do?


     


    Some system details:


    The Windows XP box isan old Pentium III with 320Mb RAM, just 1 8Mb graphics card (no dual port) and no Powerpoint installed.


    The Windows Vista box is a 3GHz dual-core Pentium D with 2Gb RAM, a Radeon X600 Pro 256Mb Graphics card and Powerpoint installed.  It is running Vista Business with SP1 and all updates.  I had just the main screen installed with no secondary screen.


     


     

  • edited July 2008
    This can sometimes happen after a re-install as a theme you previously had might have been removed. Try going into the options and changing the default theme. It might be worth setting it to a different theme, saving, then setting it back to the correct theme. (Just to be sure!!)
  • edited July 2008
    craig_linda also mentioned elsewhere that specifically setting the monitor in the settings might help too.
  • edited July 2008


    This is a bug that has happened for me in version 1.0 and now again with 1.0.1.  For some reason, sometimes when I try and remove a presentation from the list, it doesn't actually go away.  It seems like half the time it will be removed fine, and the other half it won't give me an error or anything but it will still be on the list on the left.  Most of the time when this happens if I close and reopen openlp I can then delete it fine.  With 1.0.1 however I couldn't seem to get rid of the sample presentation no matter what I did.  I finally had to go into the C:\ProgramData\openlp.org\pptdat\ and delete all the files out of that directory to get it to go away.


     Has anyone else had this problem, or better yet a solution?

  • edited August 2008
    hey there,



    it just hit me when I met with another tech guy who had openlp installed on his machine himself: his install had a service theme chooser which did not appear on any of my installs. my main installs are on a Linux Wine 1.0 machine and on a Windows XP Professional SP3 German.
    Both do not show that drop-down chooser

    We do not use this function so I never wondered how to set the service theme but it'd be to find out where it came from.

    keep up the good work!

    patrick
  • edited August 2008


    If you set the theme level to "Order of Service" in the settings dialog, that little drop down appears.

  • edited September 2008
    We had this issue aswell last Sunday. After the third song the font size increased by a third. The setting in the theme remained the same. changing the setting from 17% to 15% got us the same font size as before.

    I can't reproduce that problem either.
  • edited September 2008
    @smurray:
    I assume you use Windows Vista?
    Do you have another computer on which you can try to reproduce this? Which Powerpoint Version do you have?
  • edited September 2008
    We had that problem once again today: It occured after switching from one theme to another. But still I wasnt able to reproduce.
  • edited September 2008
    We keep on encountering this problem (both services weekly), and don't know why. I need to look at it more fully. But for the moment, we may have to revert to a previous version of the application.
  • edited September 2008


    It seems to (sporadically) happen when resizing the main window, or resizing the panels within the page, sometimes when hiding the theme manager, occassionally on change of theme.


    I keep meaning to spend some time to try and find a method of duplicating it reliably, so it'd be great if anyone can come up with specific steps that will always produce the problem.

  • edited September 2008


    I think I can reliably duplicate it.


    1. Start openlp.org (it should start up maximised)

    2. Select the "openlp.org Default Theme"

    3. Pick a song from the media manager and Preview it

    4. Double click on the openlp.org title bar to "normalize" the window

    5. Pick the same song from media manager and Go Live on it.

    6. Hopefully you'll see that the font size is different in the preview and live window.

    (This has been the case on two different machines for me)

  • edited October 2008
    I can duplicate it by opening a song, any song, going live, then moving the width of the preview/live panels, as I move these widths the font changes on the live screen, basically the font on my monitor changes on the 'live' panel, and so the font on the live projector screen is affected.
  • edited October 2008
    I too have hit "random" powerpoint issues, but all seems to work fine when I try and break it on purpose! If anyone can reliably duplicate problems with PPT please could you post the steps here with the hope we can get rid these issues.
  • edited October 2008

    We just distributed openlp.org to all the music and tech stuff, these are the bugs they reported to me (which I could reproduce)

    1. The SaveTo Destination wouldn't be remembered. Thats a little annoying.
    2. In what way do bibles get ordering? we have 7 translations and they appear in a chaotic order, my list looks like that: HfA, Volxbibel2, kjv, HFA, asv, .... It'd be good if they were sorted alphabetically
    3. Although we have disabled hot keys, we cannot use AltGr (RightAlt) + Q (which will return an @ on German keyboard layout). This problem only comes up on "real" Windows, not on WINE (of course). That is really a little problem, since we mail preparations and always have to close openlp.org to enter the email-addy.
    4. I almost forgot this one: When selecting a bible verse from the library and go live with it directly, the footer on our presentation computer at church will display the copyright twice (two lines), on my Wine it shows LyricsLiveControl at the bottom (each 3rd line of footer).
    5. when showing bible verse from the oos the second line will hold the translation name, from the library the translation name is appended to the verse address.

    thats for bugs

    I'd love to get a new bugfix release soon ;)

    god bless

    paddy2706
  • edited October 2008


    1. Is a feature request, so you'll have to catch Raoul on a good day!


    2. I'm guessing it sequences them in the order they were imported? Sounds sensible to sequence them in a case-insensitive alphabetical order though.


    3. I've duplicated this on my UK keyboard with ALTGR-a. (á). openlp.org does indeed seem to prevent you from entering this combination in any other application whilst it's running, even with hotkeys disabled.


    4 Duplicated. I think 5 is related, it looks to be showing the last thing that was displayed in the copyright field.


     

  • edited January 2009

    Using the mouse scroller doesn't work in the Live and Preview panels.

Sign In or Register to comment.