OpenLP 2.9.0 aka 3.0 Alpha 1 OFFICIAL DISCUSSION

edited January 2 in Development
I thought I saw an announcement on the Facebook page about the release of V3.0 Alpha-1 about 2 days ago, now can't find anything about it. I even commented on it. Was it withdrawn or have I had too much eggnog?
«1

Comments

  • Hey folks, I celebrated the release of Openlp 2.9 Alpha. Not for long, anyway: Trying to install it on Ubuntu 19.10 resulted in a long loading time and then the program did not start. So I couldn't even open it. Still not after a reboot. I must mention that I had installed openlp stable before. I also tried to "apt purge" openlp stable: Same result. Is this Issue already known or am I alone running into it?
    Btw: The only thing I could see of openlp, was nice: congrats for the new icon. It looks very clean and modern.
     
    The bash message:
    Traceback (most recent call last):
      File "/usr/bin/openlp", line 6, in <module>
        from pkg_resources import load_entry_point
      File "/usr/lib/python3/dist-packages/pkg_resources/_init_.py", line 3250, in <module>
        @_call_aside
      File "/usr/lib/python3/dist-packages/pkg_resources/_init_.py", line 3234, in _call_aside
        f(*args, **kwargs)
      File "/usr/lib/python3/dist-packages/pkg_resources/_init_.py", line 3263, in _initialize_master_working_set
        working_set = WorkingSet._build_master()
      File "/usr/lib/python3/dist-packages/pkg_resources/_init_.py", line 583, in _build_master
        ws.require(_requires_)
      File "/usr/lib/python3/dist-packages/pkg_resources/_init_.py", line 900, in require
        needed = self.resolve(parse_requirements(requirements))
      File "/usr/lib/python3/dist-packages/pkg_resources/_init_.py", line 786, in resolve
        raise DistributionNotFound(req, requirers)
    pkg_resources.DistributionNotFound: The 'OpenLP==2.5.dev2899' distribution was not found and is required by the application

  • Hi @joe
    Thanks for installing and providing feedback! How did you install? Using the Deb package?
  • Thanks! I'll try it on a Windows 10 test system tomorrow! Is there/should there be a V3 category or do you want discussions under Development?
  • You can just post here under Development. Please make sure to check our issues on GitLab as well, there are a lot of things we are already aware of.

  • I'm happy to see the first public Step to V3.0. Thank you!

    In my Church we are still running on V2.2. Do we have to Update to V2.4 befor the Releas of V3.0 or can we do an Upgrade from 2.2 to 3.0 direktly?
  • Sorry to say 2.2 to 3.0 has not been tested.  It would be better to install 2.4.6 then install 3.0.
    The 2.2 to 2.4.6 to 3.0 path has been tested and works without issue.
  • I was trying to test this on an older computer (Intel Core i3 CPU 540) with integrated graphics - Intel HD Driver 8.15.10.2900 (11/26/2012) running Win10-Home-x64 v1909. I installed OpenLP 2.4.6 and it ran fine. When I loaded OLP Alpha, it installed fine and was able to run setup. It updated my 2.4.6 files. However, I then got an error saying that I needed to install a driver for OpenGL 2.0. I've been unable to find a later driver from Intel which supports OpenGL. It seems that if this is a requirement, the setup procedure should check for that PRIOR to deleting the previous version and updating the data files.

    The error message mentioned some emulation files, but not sure where/how to find them. I can probably rerun with the debug version if you need more info.
  • First I want to say to the programmers..... THANKS for all you do!!!! I d/l the portable 64 OLP and was wondering if there was a transition feature for the images added to service in group. I always make custom slides as images and the transition has always been well one slide to next. No fade or anything or am I missing it??
  • Hey @ebowen I noticed that there's an inconsistency. If you have a theme that has transitions, you have to push a song or a custom slide to the projector before the transitions will work for the images. I'm going to put an issue in for this, because since the transitions do work for images, it should not be necessary to push a text-based item before the transitions work for images.
  • I've merged all the recent v2.9.0/v3.0 Alpha 1 discussions into this single discussion. Please continue discussions here.
  • Ciao, vorrei segnalare la mia breve esperienza, ho installato per prova l'ultima versione alpha su un pc con Win10 e già installata la versione 2.4.6, sono emersi una infinità di errori senza permettere al programma ad avviarsi, ho disinstallato la versione precedente e nonostante questo il prgramma non si avviava, ho dovuto disinstallare tutto, fare una copia di sicurezza del file di registro ed andare a cancellare la voce Openlp e i suoi sotto indici dalla chiave HKEY_CURRENT_USER/SOFTWARE/OpenLP, cosi facendo sono riuscito a far installare una nuova versione e provarla.
    Lo stesso problema per reinstallare la versione precedente. Quindi consiglio vivamente di non installare la versione Alpha per un utilizzo reale, ma solo per fare prove di funzionamento.

    Hi, I would like to report my short experience, I installed for trial the latest alpha version on a pc with Win10 and version 2.4.6 already installed, a lot of errors emerged without allowing the program to start, I uninstalled the previous version and despite this the program did not start, I had to uninstall everything, make a backup copy of the registry file and go to delete the Openlp entry and its sub-indexes from the HKEY_CURRENT_USER/SOFTWARE/OpenLP key, so doing I was able to install a new version and try it.
    The same problem to reinstall the previous version. So I strongly suggest not to install the Alpha version for real use, but only to test it.





  • edited January 5
    @raoul
    I'm on Windows 10 and using the portable 64 2.9. When I am testing with one screen, I select display if a single screen. it fills I am getting erratic behavior. The splash screen fills my screen along with single display with me setting smaller resolution and x &y set to 0.
  • @ebowen that's not the splash screen, that's your display screen. Try pressing Esc to clear it.
  • @raoul ;Have you tried the portable version with one screen? It is not displaying the same as OLP2. I have the logo screen covering my main screen along with a display window at 1280x720 which i set so I cant see the UI.
  • Quick Question. If i were to also update my laptop for short trial runs during practices. would I still be able to make songs on my laptop and export them, and then import them on the normal computer running OpenLP 2.4?
  • Great work, everyone - thank you for creating a great product!
    Question: where should I look to read the list of supported Apple OS versions for 3.0?
  • @ebowen I don't use Windows, so no, I haven't tried using the portable app.
  • edited January 9
    @ChrisClements Yes, exporting to and importing from OpenLyrics XML should work without a problem.
  • @JulianThomson I'm compiling on 10.14 aka Mojave, so I'm guessing 10.14 and up. Apple doesn't tend to support older versions of macOS, and at some point I'll have to upgrade ;-)
  • I tried installing the 32-bit version on a 32-bit Windows 7 Home machine and it installed but wouldn't run and gives this fatal error detected message upon opening: Failed to execute script _main_
  • Trying 2.9 on old Dell laptop with Windows 10. I want to create a theme with black text on white background. Setting the background works, but setting the text colour to black doesn't; this applies to main text and footer. If Outline or Shadow are clicked, they appear in black.
  • Hey @raoul I did get the portable to work right. I guess it was slow processing images. Will the transition work on individual images added to services using the up & down arrows to advance sildes? It works if i add multiple images as folder and use play but not single images.
  • Hi everybody, we would like to purchase a license for a PowerPoint, which version should we buy to run well with the version 3.0 of OpenLP?
    I am under win 10.
    Thanks for your wonderful job.
  • @ebowen OpenLP currently can't fade between items in the service, only between slides in an item. Fading between items in the service is a much more difficult feature to build, and I don't know if we'll have it in 3.0. We've got a lot of other stuff to do for 3.0.
Sign In or Register to comment.