Strange GUI issue

Hello Friends!

The GUI is really messed up and I'm not sure what has caused it to happen (Screenshot below). I have noticed that pressing Alt allows me to access the menus up the top but I can't see the menus, just their children/trees.

I'm running Windows 10. OpenLP 2.9.0. I've tested this on Dual Monitor and Single monitor settings. The resolution is 1920 x 1080. There is no scaling. I know that this is Alpha so this just me messing around on a spare laptop.



Comments

  • Hrm, that's quite something. I've never seen anything like it, to be honest :)

    I wonder if the layout settings from a previous version of OpenLP are causing this.
  • edited March 1
    I'm having a similar issue.

    I tried uninstalling and deleting any openlp files i could find along with uninstalling a deleting any python related things i have installed.

    I noticed that for a brief fraction of a second it looks correctly but when the program is fully loads it looks like the screen shot above.
  • Did you clear the register of all OpenLP folders?  if not Please try.
    1. shutdown OpenLP
    2. select the start button
    3. type regedit and press enter
    4. select Yes when asked if you want to let the app modify Windows
    5. expand HKEY_CURRENT_USER
    6. expand SOFTWARE
    7. scroll down until you find OpenLP
    8. select the folder and press the DEL key
    9. close the registry editor window
    10. Start OpenLP
    OpenLP will create a new and clean registry folder with the information it needs....with luck this will allow it to look right on the screen.
  • Thank you, John, for responding.
    I tried the steps you listed but that did not fix the issue. I also tried uninstalling Openlp, deleting everything in the registry and elsewhere and then reinstalling. The issue still came up so I then tried deleting the registry again then launching it but the issue is the same.
    It appears that it may be something my display or something as the interface is still there as I'm able to click on buttons that would be in their proper places. I can click on the "File" tab and open another window which works correctly.

    Im going to see if I have the same issue in a VM.

  • @EdMan ; can you give us more information about your system?  I'm running Windows 10  1909 with 4 G of RAM...and have not seen a display like yours.....more information might help us figure out what is happening.
  • A wild guess could be that you need to update your OpenGL drivers for your graphics device...
  • I have Windows 10 1909 (laptop)
    Intel Core i5-8300H
    8 gb of ram
    Nvidia Geforce GTX 1050
    OpenGL  version 4.6.0
    DirectX 12.1, 11.4

Sign In or Register to comment.