Help me fix a bug where all network activity drops while OpenLP is running

Things to know before talking about the bug:
  • even after multiple windows installs, hardware wipes, correct wifi drivers installed, windows drivers installed issue still there
  • when asked, network acces was given both for private-home and for public places to openlp
  • issue appears and can be triggered everytime after launching openLp ( both with stock settings, and with small personalised settings done)
  • de-activating the remote plugin doesnt fix this 
First I noticed almost a year ago that my phone connection to openLP would freeze every 10-20 sec for almost 10-15 seconds, no matter the phone i used or the network ( tried in different places, tested at church and home) so i basicaly gave up the feature
I later discovered that its not the phone app, or the phones connection to the laptop.
Lets say we have something active opened, like a teamviewer connection or a windows remote connection, or a mouse sharing software like Synergy ( this is what i use to control with 1 mouse and keyboard , multiple computers and screens so imagine it needs a active connection to the laptop, just like team viewer for example)
All these apps would stop working 10 seconds into openLp launch, and it would behave exactly the same as the phone remote connection.
Basicaly while OpenLP is opened, my internet connection drops for a few seconds, every 20-30 seconds. Refreshing any webpage during this time gets stucked in "RESOLVING HOST", and i have to wait a few seconds for the cycle to repeat so i can use the internet or reconnect with any remote app.
Closing OpenLP makes the network stable again and all the software works + webpages do not drop anymore.

I explained this the best way i could.
Please help!


  • I've been using OpenLP for several years and not seen this behaviour. Could you post which version of OpenLP and OS you are using?
  • @PaulRowell
    Both withdows 10 version 2004 which i upgraded to 1 day ago, and the previous 19xx before it.
    I am on latest version of openLp, and I also tested this on a manual older version download, from 1 year ago.
    Firewall is allowing home,public and work acces. 
  • Is there anything interesting in the windows system events?
  • No special message is displayed. Internet just drops and task manager shows wifi going instantly to 0kb/s.
    About events manager, I wouldn't know what to differentiate in there..
  • My gut instinct is that it is something outside of OpenLP that is causing the behaviour you are seeing. There are many people using OpenLP weekly and I can't recall this problem being reported here before, although my memory is definitely not as sharp as it once was! Do you use WiFi for both the phone and the pc you are running OpenLP on? I use a wired connection for my OpenLP system.
  • Yes, same wifi, but it doesnt go off for the phone. Also theres a internet cable from that router going to my PC, which also doesnt drop signa.
    Would you like to take a look with team viewer ? Im about t ogive up on openlp because i cant figure this out for many months now.
  • What time zone are you in? I'm in the UK so on BST currently. I can take a look, but I'd be inclined to just use the wired connection for the PC and not have both WiFi and cabled connections.

  • @laurentiudll ; I have been using version 2.4.6 for a few years on Windows 10 version 19xx and have not had this issue.  I have used NDI streaming on the same laptop with OpenLP and never dropped any connections on WiFi or LAN. 

    I did have an issue once when behind a VERY strong firewall where the Android remote would keep switching between the WiFi and Cellular kept thinking the WiFi was broken because it couldn't reach any normal internet stuff....Great FireWall!  Nothing gets through!  switching off the cellular data on the phone fixed this issue.

    By any chance is the WiFi connection shown as having "no internet"? or is there another WiFi signal near by that might be more tempting for Windows to look at?  Windows sometimes likes to try new WiFi access points if it feels they might be faster.  Telling Windows to be less aggressive about roaming to new WiFi access points might help if this is the case.
  • Hello, have this issue been fixed? I am facing completely same problem as described here. I just faced this when I had zoom chat with my friends and wanted to show them something in OpenLP. After I've opened the app, my connection started to continuously freeze everz 10-15s for about 2-5s. When I closed OpenLP app the connection was fine and working with no issues. It's happening to me only when opening OpenLP app. I've tried same with different programs, games etc. and didn't face anything like this.

    Any idea where could be the issue, please? This really makes me little bit crazy, because we would like to run live stream also using OpenLP and with this my connection is always breaking down.
  • edited November 2020
    Maybe I've found some root cause. When I am on wifi on my laptop, there is the issue mentioned, however when I turn off my wifi and connect via LAN cabel, there is no such problem. However the issue via wifi is still there and I would like to have it fixed, because during my streaming, I will not be able to have LAN connection.

    version: OpenLP 2.4.6
    OS: Windows 10 Home version 20H2
  • @zmar89 Do you have the remote enabled? Try disabling it.
Sign In or Register to comment.