OBS Stream Interruption

I am running OpenLP 2.4.6 on Windows 10. Also running Open Broadcast Studio (OBS) to stream services. The outbound stream is healthy when just running OBS. As soon as I run OpenLP, the stream starts dropping frames. It drops frames once every 5 seconds. I disabled the remote and alert plugins and thought that solved the problem. Turned them back on to see if the problem returned. It did, so I disabled them again, restarted the computer and tried streaming again. Same problem. Any ideas?

Comments

  • Sounds like your computer run out of ressources, please check is there a minimum of 200mb free system ram available and is the cpu at least not more than 80% under load? Why I'm asking this? Videorendering is heavy in CPU load and if Open LP uses also somethimes a little CPU you can imagine. If you run out of free Memory the System writes massivly on the harddisk this will slowdown the hole System noticable and can produce such drops like you've encaunter.

    Greetings Simon
  • Computer has 8GB RAM, and task manager says it is only 41% utilized. CPU maxes out at 14% when the stream is interrupted. Computer has a GPU engine and it is up around 34% when the stream is interrupted. I even tried doig a clean boot - turned off all non MS services. It cleared up some RAM but hasn't change the situation. OpenLP CPU and memory usage doesn't change much when the stream is interrupted. I agree it should be a resource problem but I can't see a resource problem. Thanks.
  • What's the resource usage like with only OpenLP running? Do you have Microsoft Office or LibreOffice installed? Do you use presentations during the service? If enabled, OpenLP runs your presentation application (PowerPoint or Impress) behind the scenes for when you need it. Perhaps your office suite is what's causing the problem?
  • Streaming video is resource intensive. I have noticed that if updates are being checked/installed at the same time as I'm streaming it can cause frames to be dropped.

    Looking at the figures you have posted I'm wondering whether a core on your CPU is nearly maxed out...
  • No Office apps are running, no updates are being installed. I can reproduce the problem without a service loaded into OpenLP, not even projecting live.... just running. The computer we are using has always been deathly slow when doing anything intensive so I suspect there may be deeper problems. When I run the same setup on my MacBook Air, I do not experience any problems. Thanks for all the suggestions.
  • Its quite hard to tell from far. Do you have a harddrive or ssd and record at the same time? As Paul Rowell said, there could also be network traffic affecting the stream but it doesnt make sense when it's ok with only OBS running. What Anti-Virus and Firewall Software are u using. They can somethimes be nasty. Please try to disable them for testing purpose and give us feedback so we can try to help you as much as possible. You can also disable windows update service for testing. Quite difficult from the far...
  • Thank you for keeping the conversation going. The computer is an ASUS SonicMaster with a GPU. I did notice a correlation between a hit against the GPU (and GPU engine process in Task Manager) and the stream interruption. I am running BitDefender, and yes it uses a lot of resources. I tried to disable it for testing but wasn't successful. I will have to try uninstalling it. I'm also considering trying a system reset. I can backup my OpenLP content databases so that I can restore all the songs and custom slides we have created. The only two programs I use are OpenLP and OBS so it's not a big deal to re-install. I will let you know how it goes.
  • Ok, two ideas beside Bitdefender. First: today i had trouble at work with a gpu, solution was to set energy settings in nvidia controlpanel to max. Performance. Second the Notebook should get a SSD, it's much quicker.
Sign In or Register to comment.