OpenLP on Ubuntu using older computers 32bit and 64bit

I'm experimenting with Ubuntu to find the best Ubuntu version for older computers when using OpenLP. I train churches on how to use OpenLP 2.4.6 on Windows 7 & 10, MacBookPro, iMac and now Ubuntu. Older computers with 4GB of memory will run Ubuntu 14.04 on 32bit and 64 bit computers, but have speed and other problems with 16.04, 18.04, 20.04.

When Open 3.0 comes out I suspect it will probably work best on newer computers using Ubuntu 20.04. I'm testing Ubuntu & OpenLP on an old Dell Optiplex GX 620 32 bit with 2GB of memory, and on a Dell Optiplex 760 64 bit with 4 GB of memory. I offer free training for churches with limited funding to help them get started in my area. I've already successfully setup and trained for OpenLP usage on Windows 10 with just about any computer that will run Windows 10. I only have six computers on my development and test. On Ubuntu I've found that the 14.04 works the best on old computers. You can use the VLC that comes with 14.04, but I suggest using the deb for openlp_2.4.6-1_all.deb from the openlp website at <a href="#">https://get.openlp.org/2.4.6</a> for both 32 bit and 64 bit computers.

Please, leave comments! I welcome help!

Comments

  • edited January 8

    Instruction for setting up Openlp 2.4.6 on Ubuntu 14.04 32 bit or 64 bit with a minimum 4 GB memory for best results on overhead projector. NOTE: I tried it with a 32 bit 2 GB memory, and it works but is a little slow.

    Please be careful! A mistake can destroy your computer's operating system, and I cannot promise that this will work for all computers. Therefore, I suggest this only be use by computer specialists with knowledge of multiple OS systems.

    Do not physically connect the projector to computer until instructed.

    (1) Burn an ISO DVD from 32-bit PC (i386) desktop image or 64-bit PC (AMD64) desktop image from https://releases.ubuntu.com/14.04/

    (2) If you already have a Windows 7 or Windows 10 system then use the DVD to install Ubuntu WITH Windows (dual boot), or install Ubuntu only as the only OS for the computer you are using. I believe by default that the Ubuntu Install will split the HD to about 50% (half Windows and half Ubuntu) automatically unless you provide other instructions.

    (3) "reboot" your computer to Ubuntu 14.04

    (4) Open Settings, Software and Updates. The add the repository ppa:openlp-core/release

    (5) Open Terminal window and run "sudo apt update", let the new installation update.

    (6) "reboot" your computer to Ubuntu 14.04

    (7) Open Terminal window and install VLC, "sudo apt install vlc".

    (8) Go to https://get.openlp.org/2.4.6/ and download the file "openlp_2.4.6-1_all.deb" to the desktop of your Ubuntu screen. Double-click this file on the desktop and install Openlp 2.4.6. (Do not run openlp at this point)

    (9) Open Settings, Appearance and set the background color to black.

    (10) Physically connect the projector to the computer.

    (11) Open Settings, Display and you should see both your display with computer and the overhead display. The probably Mirror the same Ubuntu desktop. Deselect "Mirror" option. With "Launcher placement" set you display 1 (computer monitor) as the only one for Launcher. Select "Display with largest control". Display 2, the projector display should be moved to be to the right of Display 1. If you get an error with selecting "Apply" then move Display 2 to under Display 1 and the "Apply" should work.

    (12) Open/run the openlp program. If openlp does not display the openlp icon on the projector screen, the in openlp select "Settings, Configure OpenLp..." and see that "General, Monitors" is set to "Screen 2"

    You should be up a running. I suggest a reboot to see if everything works ok now.

    Hope this helps!

  • edited January 8

    NOTE: When Ubuntu asks if you want to upgrade to 16.04 say no. You can always go back and update if you want to! But with old computers it will not run as fast and other problems occur. Best I've found for old computers is 14.04.

  • Thanks for your instructions. Did you ever try Mint 20 XCFE? That's pretty small and should work on older computers too.

  • No, never tried Mint 20 XCFE! Will look into it!

  • edited January 12

    Fabster,

    Thanks so so much. Linux Mint Xfce 19.3 on 32bit computer and Linux Mint Xfce 20.1 on 64bit computer worked as a dual boot with Windows 10. What's even better is that OpenLP works great on both computers performing fantastic. Best solution since "ice cream"! Both OpenLP and VLC installed and ran perfect with no error from Terminal.

    I've been using Linux for years, but this was the first I've seen of Linux Mint. It looks like this is an upgrade on Ubuntu 20?

    Again Thanks so much!

  • NOTE: I have a 64GB SDC card with my OpenLP setups. I install OpenLP on Windows 7,10; on MacBookPro & iMac; or on Linux Mint. I have OpenLP Setting configuration files (.conf) for each type OS. I use these configuration files to setup OpenLP with all of my libraries of Songs, Bibles, Presentations, Images, Media, and Custom slides. This way I can take my SDC to home and church and use the same OpenLP database.

    I love it and Linux was the final challenge. Thanks again so so much!

  • @Johnny Fowler glad that Mint XFCE works well for you! In fact, Mint is a fork of Ubuntu, with some adjustments and a better usability (in my opinion). And the XFCE Desktop is very lightweight, so it works well on older computers. It's mostly the desktop that uses computer resources...

    Good hint with the sdc card. I will try that with an usb-stick.

    God bless!

Sign In or Register to comment.