Custom Slide Adding A Slide Even Though It Isn't There

I created a custom slide that only contains one slide (that sounds weird).

The problem is that Preview and Live are both showing an extra slide that is all black (and it goes to the screen when you hit the Down key).


I'm trying to attach screenshots, but I keep getting a 413 error.

The Custom Slide only has the one text slide and there isn't a code hard break or anything (unless "front" is interpreted as a break).

As an interesting second issue, screenshots aren't showing what is actually showing on the second monitor.

It's showing a previous Bible slide, even though this slide is in the Live window and it's showing on the monitor.

I wonder what's up with that?




  • Clear your browser's cache on this page to try fix the attachment issue.

    What version of OpenLP are you running?

  • OpenLP 2.9.2

    I cleared the cache.

    You can see that there is no extra line, space, or break, yet it creates a new slide.


  • @doubleJ From the looks of your preview slide your wording is a character too long for a single slide and OpenLP is "splitting" the slide into two slides.

    I would suggest going into the custom slide and editing the first slide. Put your cursor on the line below the text in the edit window and left click you mouse.

    If the cursor goes to the line below your text, press the Backspace key. The cursor should move to the last character of your line of text. If it is out a space or two, press the Backspace key until the cursor is at the last character of your text.

    If you didn't find any spaces while trying the above, edit the theme your custom slide is using and drop the main font size by 10 points. This should allow an extra characters worth of space. You could change the size of the main area in the theme, but this takes some experimenting to make sure the edges of the screen are visible!

    Once you get to the point where the text is displayed on one slide you can make adjustments to both the theme and the custom slide to get it to display exactly as you want it to.

  • I don't think the length is the issue.

    There were no extra spaces and there wasn't an extra slide, below the main slide, to select.

    I removed everything except "YES! You are welcome to get", which is nine words less and it still had the extra slide.

    I deleted the text slide and re-added it and it still had the extra slide.

    I deleted the custom slide and recreated it with just an empty text slide (Added a slide, hit the spacebar, hit the backspace key, saved) and it only had 1 slide.

    I added a text slide that only said "YES!" and it added the extra slide.

    Any other ideas?


  • Looks like a bug to me. I believe I patched this issue or something similar 2 months ago, but there has not been a release since then. Try it again when the next release comes out, and if it still has the problem we'll raise an issue on the issue tracker.

  • @doubleJ would you be willing to try a more current development version of OpenLP? The version is only Win 64bit...I hope it will work for you. Please backup your database and setting before installing this...I don't expect any issues as I have been going back and forth with the development versions myself...but it is best to do your backup!

    Please let us know if you can install this newer version and if it fixes the extra slide issue.

Sign In or Register to comment.