No bold text on new MacBook

I've just replaced my MacBook with a new model - so the M1 Apple Silicon and Big Sur.

I've copied the databases and settings from the old MacBook and OpenLP is running just fine with one exception - no bold fonts. In themes with Bold selected, or themes without it but where the text uses the st (strong) tag, the text simply isn't bold - it is the same weight as the non-bold text.

Does anyone have any ideas on how to fix this?

Comments

  • edited March 25

    Have you tried different fonts? If you use a word processor, can it use bold fonts?

    A possibility is that Mac is reporting the bold font as a separate font rather than a variation. Are there fonts that have "bold" in the name? (eg: "Arial bold")

  • I have tried both Arial and Helvetica to no avail. I can select bold in other apps (e.g. Pages).

    Also, the font selection in OpenLP doesn't show a separate bold version of the font.

    I have also tried reloading the Standard Fonts (in the Font Book app - which also shows that Arial has Bold as well as Italic. Note that Italics are working.

    My OpenLP version is 2.4.6, by the way (forgot to say on the previous post).

  • There have been a few changes to how fonts are handled in the beta. Give it a go If you have some spare time to test the beta. Just remember to click "yes" when it asks you if you'd like to back up OpenLP data.

    I don't think any of the developers has a modern Mac so testing on that platform is somewhat limited.

  • OK - I've now loaded the Beta version and it appears to recognise Bold fonts, so I'll go with that for a while.

    (If I have any issues, I can always have my old MacBook ready as a backup for live services.)

    Before I loaded the Beta, I compared all the settings against my old MacBook (MacOS 10.11) and noted one anomaly - in the Players section on the new Mac it shows "VLC (unavailable) NOTE: To use VLC you must install the 64bit version". Now my 2.4.6 install must have been 64bit as Rosetta won't translate 32bit Intel apps - but this definitely suggest that the translation through Rosetta for the M1 chipset is throwing some system detection stuff off.

    I appreciate that the devs won't have M1 chipsets yet and so a Universal version of OpenLP (with native Apple Silicon support) may be a while off - and will probably only be in the 3.0 release and not the 2.4 branch. But hopefully this information will help any other queries until then.

  • Thanks for the update. It great to hear that fonts are working.

    OpenLP is written in python, which supports the M1 architecture. So when we update the python version used, perhaps it will integrate better with other apps in the system like vlc.

  • Just to note that I have also seen the same issue with bold fonts with 2.4.6 on an M1 Mac. (I haven't braved the beta yet.)

Sign In or Register to comment.