Installing 2.4.6-x64 in Win10 after trying and uninstalling 2.9.2

edited May 10 in Troubleshooting

Hi,

We use OpenLP 2.4.6 at church, and I have just tried out the new beta version 2.9.2-x64 (on a Win10 PC that’s not had an OpenLP install before). After trying it, I uninstalled it and installed 2.4.6-x64 but the Library section was blank, and when trying to re-run the setup wizard, I get…

Traceback (most recent call last):

File "openlp\core\ui\firsttimeform.py", line 313, in on_current_id_changed

File "openlp\core\ui\firsttimeform.py", line 210, in _download_index

AttributeError: 'NoneType' object has no attribute 'is_active'


After removing 2.9.2 and the 2.4.6 not installing correctly, I uninstalled 2.4.6 after trying again, then deleted the OpenLP under c:\users\<user>\AppData Local & Roaming, and tried installing 2.4.6 again, getting the above.

How can I ‘clean’ my PC so that 2.4.6 can install correctly? Are there registry settings that need to be deleted?

Many thanks

Comments

  • I had the identical experience on MacOS 10.15.7, trying to revert to 2.4.6 from 2.9.2 and then reinstall 2.4.6 after deleting the openlp folder from Application Support. Traceback on the 2.4.6 app launch:

    Traceback (most recent call last):

     File "openlp-run.py", line 44, in <module>

     File "openlp/core/__init__.py", line 437, in main

     File "openlp/core/common/openlpmixin.py", line 58, in wrapped

     File "openlp/core/common/openlpmixin.py", line 54, in wrapped

     File "openlp/core/__init__.py", line 142, in run

     File "openlp/core/common/registry.py", line 137, in execute

     File "openlp/core/common/openlpmixin.py", line 58, in wrapped

     File "openlp/core/common/openlpmixin.py", line 54, in wrapped

     File "openlp/core/lib/pluginmanager.py", line 68, in bootstrap_initialise

     File "openlp/core/common/openlpmixin.py", line 58, in wrapped

     File "openlp/core/common/openlpmixin.py", line 54, in wrapped

     File "openlp/core/lib/pluginmanager.py", line 180, in initialise_plugins

     File "/Applications/OpenLP.app/Contents/MacOS/plugins/media/mediaplugin.py", line 70, in initialise

      super().initialise()

     File "openlp/core/lib/plugin.py", line 278, in initialise

     File "openlp/plugins/media/lib/mediaitem.py", line 296, in initialise

     File "openlp/plugins/media/lib/mediaitem.py", line 357, in load_list

    AttributeError: 'str' object has no attribute 'sort'

  • edited May 11

    You need to delete the configuration file/registry. See where to find it here: https://manual.openlp.org/faq.html#where-do-i-find-the-configuration-file

  • I followed those instructions for MacOS to try to uninstall 2.4.6 before installing 2.9.2 and then when trying to reinstall 2.4.6. That plist (preference) file was deleted during the original uninstall procedure. The app keeps saying that it's still open then crashes, even after emptying the trash and restarting the computer.

  • I'm stumped. I'll tell you if I find out what the issue is.

  • Deleting ~/Library/Preferences/org.openlp.OpenLP.plist worked for me.

    There was also an old org.openlp.plist that I deleted before running openlp 2.4.6 again.

    I lost some of my old setup, but oddly enough, some things were retained (songs, bible, some images, custom slides, themes).

Sign In or Register to comment.