QtWebKit deprecated?

I got the following error message trying to fire up OpenLP in Linux Mint 20 Ulyana:

Traceback (most recent call last):
  File "/usr/bin/openlp", line 27, in <module>
    from openlp.core.common import is_win, is_macosx
  File "/usr/share/openlp/openlp/__init__.py", line 26, in <module>
    from openlp import core, plugins
  File "/usr/share/openlp/openlp/core/__init__.py", line 41, in <module>
    from openlp.core.lib import ScreenList
  File "/usr/share/openlp/openlp/core/lib/__init__.py", line 327, in <module>
    from .htmlbuilder import build_html, build_lyrics_format_css, build_lyrics_outline_css
  File "/usr/share/openlp/openlp/core/lib/htmlbuilder.py", line 392, in <module>
    from PyQt5 import QtWebKit
ImportError: cannot import name 'QtWebKit' from 'PyQt5' (/home/robert/.local/lib/python3.8/site-packages/PyQt5/__init__.py)
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 153, in apport_excepthook
    with os.fdopen(os.open(pr_filename,
FileNotFoundError: [Errno 2] No such file or directory: '/var/crash/_usr_share_openlp_openlp.py.1000.crash'

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/openlp", line 27, in <module>
    from openlp.core.common import is_win, is_macosx
  File "/usr/share/openlp/openlp/__init__.py", line 26, in <module>
    from openlp import core, plugins
  File "/usr/share/openlp/openlp/core/__init__.py", line 41, in <module>
    from openlp.core.lib import ScreenList
  File "/usr/share/openlp/openlp/core/lib/__init__.py", line 327, in <module>
    from .htmlbuilder import build_html, build_lyrics_format_css, build_lyrics_outline_css
  File "/usr/share/openlp/openlp/core/lib/htmlbuilder.py", line 392, in <module>
    from PyQt5 import QtWebKit
ImportError: cannot import name 'QtWebKit' from 'PyQt5' (/home/robert/.local/lib/python3.8/site-packages/PyQt5/__init__.py)

I'm not sure if it's related to the deprecation issue or not, but I ran across this: https://stackoverflow.com/questions/37876987/cannot-import-qtwebkitwidgets-in-pyqt5

Thanks!

Comments

Sign In or Register to comment.