Looped PP Presentation(.pptx) Not Looping When Played Through PP Viewer 2007 & OLP 2.4.6 on Win 10

edited November 4 in Troubleshooting

To elaborate on the title summery. Playing a timed, looped PowerPoint presentation, stand alone, through PP Viewer 2007 loops fine. However when the same presentation is played through OpenLP's presentation plugin the presentation ends at the last sequential slide.

Being a programmer in a past life, seeing this behavior, allow me to float a theory. It seems to me there is a FLAG in the presentation file to PP Viewer that signals the looping behavior of the presentation that OLP's presentation plugin is not aware of. In other words, whatever FLAG OLP's plugins uses to determine the end of a PP presentation does not take into account this looping FLAG in the presentation.

A bit of logic from a fellow programmer, passed his prime, to lend a head start on the issue.


On a side note, regarding the presentation plugin. Whether the presentation be PP or Libre Impress the plugin's exit behavior IMHO should be the next Service list item.0


Thank you for your awesome efforts and allowing me to share my observations and humble theories.

Comments

  • Thanks for the theory. Unfortunately PowerPoint Viewer is not really supported by Microsoft anymore, and the last time we tried to get it working, nothing worked, so in future versions of OpenLP we've removed support for it. It was always a weird implementation anyway.

    As a free alternative, you could try LibreOffice.

Sign In or Register to comment.