OpenLP 2.4.6 Crashing on Windows 10

I've used OpenLP 2.4.6 for several years but have never had an issue with it crashing like it is doing now. I haven't used it in about 4 months due to an attempt to use another presentation software at church but due to issues I decided to come back to "old reliable" OpenLP BUT it has been crashing on me at home when I double click on an item in the service manager. I get an hour glass and then after about 10 seconds it closes. It will happen several times (crash and I restart) and then OpenLP will work fine after restart. Once it is working correctly (able to double click on a service item), it seems to be difficult to get it to crash in that session. It is like the program comes up ready to work correctly OR it is going to crash when I double click on a service item. Really odd and not easily repeatable. The service items are all powerpoint slides which have been saved as .jpg files.

OpenLP- 2.4.6

Windows 10 -Version 10.0.19043 Build 19043

PC - Ryzen 2600, 16GB RAM, SSD

Any suggestions on how to fix this issue?

Thanks

Greg

Comments

  • Are you getting any error message at all? Can you check the log file (see the FAQ in the manual)?

    Can I also suggest you try the release candidate? You'll need to back up your configuration (again, see the manual), but it's pretty stable already, and we're not working on 2.4.6 anymore.

  • My OpenLP 2.4.6 on Windows 10 also stopped working on March 12, it left a openlp.log file attached. Since then if I run it nothing ever appears, no openlp.log but a process remains running.

    I understand that the release candidate is probably the solution. Not yet managed to get that running om the 1GB Raspberry Pis I use for presentation for the last 5 year.

    Will find a temporary solution.

  • @simondgoodfellow Aha! Thank you! The log file says that the version file that OpenLP looks for on our server is missing. I'm not sure why, but I'll take a look and see if I can figure out what happened there.

  • Thanks, that has fixed the issue for me!!

  • I spent many hours preparing the songs for our service this morning and nothing .... Open LP would not load my service file and it then crashed on the the computer.

    I have been totally unable to load version 2.4.6 on my desktop. Today I have deleted Open LP (several times), restarted my PC and attempted to re-load, but each time there is no media (library, bibles, presentations, images, media or custom) available and the plugins (alt & F8) is completely blank.

    When I first used Open LP I was unable to load version 2.4.6 and so I loaded 2.9.4 and thought all was well, but we think that my use of 2.9.4, and using that version to compile the songs for the service this morning, may have cause the issue. I have un-installed Open LP progarm and also deleted the data in AppData\Roaming\OpenLP, but I am still unable to manage a clean install.

  • @gwmac55 We don't support downgrading OpenLP from later versions to earlier versions. Also, without any further information about the crash you experienced, we cannot solve your problem.

    Also, did you look at the troubleshooting section of the manual? It has some tips and tricks you might find helpful, including how to get the log file and post it here so that we can look at what's happening on your computer.

  • Hi Raoul,

    Thanks for getting back to me.

    My problem first occurred when I initially tried to load 2.4.6. I tried many times, but my PC would not load and kept informing me it could not find an internet connection to load the configuration. I tried loading the beta version 2.9.? and that seemed to work, but when I tried to load the service onto the church computer it could not find the service and it then crashed the computer. Only after a couple of clean re-loads did we get the church computer working.

    I have tried to load 2.4.6 onto my PC many times now, but keep getting the same problem, AND the last few times nothing is loaded in the library or plug-ins. I attempted to send an error message to the bugs@openlp.org web address, but it came back as undeliverable. Below is a copy of the error message I was trying to send.

    Traceback (most recent call last):

     File "openlp\core\ui\firsttimeform.py", line 313, in on_current_id_changed

     File "openlp\core\ui\firsttimeform.py", line 210, in _download_index

    AttributeError: 'NoneType' object has no attribute 'is_active'

    --- System information ---

    Platform: Windows-10-10.0.19041-SP0

    --- Library Versions ---

    Python: 3.4.4

    Qt5: 5.5.1

    PyQt5: 5.5.1

    QtWebkit: 538.1

    SQLAlchemy: 1.0.11

    SQLAlchemy Migrate: -

    BeautifulSoup: 4.4.1

    lxml: 3.4.4

    Chardet: 2.3.0

    PyEnchant: 1.6.6

    Mako: 1.0.3

    pyICU: 1.9.2

    pyUNO bridge: -

    VLC: - 

  • edited March 31

    I attempted to send an error message to the bugs@openlp.org web address, but it came back as undeliverable.

    This is because we shut it down because we're no longer developing 2.4.6. Our issue tracking system was getting overloaded with bugs that were either no longer relevant due to code changes, or already fixed in 2.9.x.

    Could you try 2.9.4 again and find the error message? All we are currently doing is fixing the last few glaring bugs in that version before releasing version 3.0.

  • My church is using 2.4.6, so I would really like my home PC to be compatible.

    Have you any suggestions as to why each time I install 2.4.6 I have no data in library - no songs, no bibles, no nothing.

    I am doing song projection again in a couple of weeks, but since I am still unable to download it at home I am actually dreading my next time at the church!

  • OpenLP doesn't ship with any songs or Bibles. Did you go through the First Time Wizard? That gives you the option to download some public domain songs and Bibles. Also, you can export the songs from OpenLP at church and then import them at home.

Sign In or Register to comment.