Using OpenLP to show presentations via Impress always show on computer monitor not display screen

I am wondering if anyone else is having this issue. In OpenLP 2.9.4 I have three screens, computer monitor (openlp primary screen), screen two (used to show customer stage or main view) and screen three (openlp display screen). I am running Windows 10 on a HP which has three video ports, 2 display ports and 1 RGB port. The RGB port (which is screen 3 in openlp) is using a converter to go from RGB to hdmi and then the hdmi is running to a splitter for two tv's and another computer which uses OBS to capture the display screens for our live feed. Everything was working just fine until last Sunday when using openlp to show a presentation, using Impress, and it now only shows the presentation on the computer monitor (which is the primary screen in openlp). When I load Impress outside of openlp, it shows the presentation just fine on the display screens. It is only when openlp invokes impress to show the presentation does it switch to the computer monitor. I have tried changing the screen setup within openlp, but it doesn't matter, it still only shows it on the computer monitor. Is there some setting I don't have set right? If there is any additional information needed please let me know.

Comments

  • Did you check the display settings in Windows? I know that in the past there have been issues with Windows incorrectly identifying the primary monitor for OpenLP.

  • I have checked and noticed Windows when it starts will sometimes re-designate monitors. For example, the computer screen will be designated as screen 1, the TV's up by the stage as screen 2 and the TV at the back of the auditorium as screen 3. Then when I turn off the computer and turn it back on it will reassign with the following, computer monitor as screen 2, TV's up by the stage as screen 1 and the TV at the back as screen 3. When this happens the slide show settings in Impress get mixed up. However, I can adjust those settings and get Impress to show on the correct screens. When I try to run an Impress presentation through OpenLP, it always shows on the computer monitor. Do you know of a way to get Windows to stop reassigning the displays? What is weird is I have the same setup at my home and everything works just fine. The only difference is the computer, the one at church is an HP, while mine is custom built.

  • I don’t use Windows.

    And I don’t use Impress.

    With those two things understood, I wonder if what you’re experiencing is what also has happened to me on Mac, and using Keynote. My (occasional) problem is not in the operating system settings. It’s not even, in Keynote at least, in the preferences of the application.

    Rather, on the screen that is monitoring the presentation (but should be showing the presentation), there is a sub-menu which, amongst a couple of other things, allows the operator to control which screens display the different things that you want displayed. BUT …

    That sub-menu (again, on Keynote) appears when the mouse cursor is moving. And it disappears shortly after the mouse has stopped. You have to be quick!

    As I said, I don’t use the same systems as you do, but my symptoms occasionally match yours. It might be worth investigating.

    Regards,

    Andrew

  • Thanks for the input, but I found a setting within OpenLP which allows OpenLP to let Impress use it's own settings and this fixed my problem.

Sign In or Register to comment.