Screen goes wonky. Cannot read screen after opening OpenLP. 1080i issue?


I am having a problem trying to run openLp 2.9.x. I have a two display setup. I can start up windows and everything seems to be working fine. I have can see apps on both screens. As soon as I open up OpenLP the OpenLP projection screen gets all ghosty and very hard/impossible to read. From what I can see the problem is that OpenLP seems to be changing my display settings from 1080i (interlaced) to 1080p (non-interlaced). This causes a problem since I am unable to change it to 1080p since one of the devices I use coming off that port does not support 1080p. I am hoping there is a way around this, or someone can help me solve this.

I first tried on v2.9.4, also tried v2.9.2 with same problem. Using Windows 10 Pro 21H1.


  • No, I have an AMD Radeon HD 6670. But I don't think it has anything to do with the graphics card. If I don't open up a v2.9 Open LP everything is working fine. I can see everything fine on the display/projector being used for the OpenLP. It isn't until I open up OpenLP 2.9 that the dispay essentially quits working. The problem is definitely that the resolution for that display is getting changed from 1080i to 1080p which does not work for my display. It seems like OpenLP is changing this for some reason since I can see the resolution change after OpenLP starts up.

  • OpenLP doesn't do anything with your screens, and it definitely doesn't change resolutions or anything else like that. It simply puts a window on your selected display screen. Something else is happening there.

  • There is a point while the splash screen is up that the screen goes blank. It is after this that the projection screen quits displaying things. I assume this is when the program tries to "take control" of what is being displayed on the screen. Do you know what OpenLP uses to control the screen? If OpenLP is not directly changing from interlaced to progressive then there is something it is doing that is triggering it. If I go in and change the resolution and then change it back the screen starts workign again, but the OpenLP content just shows a white splash screen type thing with the logo and never shows what is.

    Can someone try using there system with the projection display as 1080i and verify it still works at 1080i? I could accept that my PC is to old (it is probably 5-8 years old), but would like to be confident a new Pc would fix the problem and not and issue with my displays setup. This is much harder to change since I have a TV production switcher, Video Camera, and projection screen in the mix and cannot change to something progressive scan.

    The one thing that seems wired to me is that there is not problems when I run OpenLP 2.4.6

Sign In or Register to comment.