Unable to start OpenLP since enabling media plugin

Tried to submit this via email but email to bugs@openlp.org bounced back.

After having the media plug in disabled for several months I re-enabled it this past weekend. Since doing this I am unable to start OpenLP (v 2.4.6) and consistently get the below bug:

Traceback (most recent call last):

File "<string>", line 44, in <module>

File "openlp\core\__init__.py", line 437, in main

File "openlp\core\__init__.py", line 142, in run

File "openlp\core\common\registry.py", line 137, in execute

File "openlp\core\lib\pluginmanager.py", line 68, in bootstrap_initialise

File "openlp\core\lib\pluginmanager.py", line 180, in initialise_plugins

File "C:\Program Files (x86)\OpenLP\plugins\media\mediaplugin.py", line 70, in initialise


File "openlp\core\lib\plugin.py", line 278, in initialise

File "openlp\plugins\media\lib\mediaitem.py", line 296, in initialise

File "openlp\plugins\media\lib\mediaitem.py", line 357, in load_list

AttributeError: 'str' object has no attribute 'sort'

Once this is closed I get the following message:

OpenLP returned -1

Does anyone know how to fix this. I've tried uninstalling the programme and reinstalling it. Do I need to resort to deleting all the programme files etc and then trying to reinstall it? I will be trying the newer version as soon as it's stable enough, but for the moment need to stick with this version as it's the same version used on our church PC.

All help appreciated.

Sign In or Register to comment.