Launches, but unable to load a service or add to a new one?

edited June 3 in Troubleshooting

Help! I am unable to get past the attached screen shot:


I can click load recent service, it show the blue bar at the bottom, it goes, but nothing is added?

I can do the same with starting a new service....same result, clicking the + to add a song does nothing.

I can hit the projector button and screen goes black, and esc works to bring me out of it again,

All the menus along the top work (the openlp is responding...just unable to conduct a service).


Mac OS

Monterey 12.3.1 (21E258)

Comments

  • I have a similar problem. I installed the latest version and didn't like it so I uninstalled it. Then I reinstalled the previous verison. I got a bunch of errors as shown in the photos. I can't import songs or Bibles. I can't open services. When I try to send the support file shown below it does nothing. I ever have problems closing the program.

    Error messages on trying to open a service:

    Traceback (most recent call last):

    File "openlp\core\ui\servicemanager.py", line 440, in on_load_service_clicked

    File "openlp\core\ui\servicemanager.py", line 766, in load_file

    File "openlp\core\ui\servicemanager.py", line 825, in process_service_items

    AttributeError: 'NoneType' object has no attribute 'service_load'

     Error messages on trying to close the program:

    Traceback (most recent call last):

    File "openlp\core\ui\mainwindow.py", line 1091, in closeEvent

    File "openlp\core\ui\mainwindow.py", line 1129, in clean_up

    File "openlp\core\lib\pluginmanager.py", line 189, in finalise_plugins

    File "C:\Program Files (x86)\OpenLP\plugins\songs\songsplugin.py", line 328, in finalise

    self.song_import_item.setVisible(False)

    AttributeError: 'SongsPlugin' object has no attribute 'song_import_item'



  • @Sampson In the view menu, you need to make sure there are check marks next to all the items (Library, Service, etc).

  • @mildredlkoehler OpenLP doesn't support "downgrading" aka going back to the previous version. You will need to remove all of OpenLP's configuration and data files and then restart OpenLP.

    See the following sections in the manual for some clues:

Sign In or Register to comment.