OpenLP 2.4.6 Launch Fedora 36

edited August 4 in Troubleshooting

I'm running Fedora 36. At command line, I ran sudo yum install OpenLP. Then OpenLP. After the first time setup questions, I get

QSocketNotifier: Can only be used with threads started with QThread.

In a new attempt to launch OpenLP, I get to error reporting.

**OpenLP Bug Report**

Version: {'full': '2.4.6', 'version': '2.4.6', 'build': None}


--- Details of the Exception. ---


Launch after running setup wizard.


 --- Exception Traceback ---

Traceback (most recent call last):

 File "/usr/lib/python3.10/site-packages/openlp/core/ui/exceptionform.py", line 168, in on_save_report_button_clicked

   report_file.close()

UnboundLocalError: local variable 'report_file' referenced before assignment


--- System information ---

Platform: Linux-5.18.13-200.fc36.x86_64-x86_64-with-glibc2.35


--- Library Versions ---

Python: 3.10.5

Qt5: 5.15.5

PyQt5: 5.15.6

QtWebkit: 602.1

SQLAlchemy: 1.4.39

SQLAlchemy Migrate: -

BeautifulSoup: 4.11.0

lxml: 4.7.1

Chardet: 4.0.0

PyEnchant: 3.2.2

Mako: 1.1.4

pyICU: -

pyUNO bridge: 7.3

VLC: -


What does this mean?

Comments

Sign In or Register to comment.