Should we have a separate discussion thread for the newest release? (2.9.5)

I don't know what has caused this problem. I suppose that if I did know, I could fix it myself! What I'm trying to say is that I don't know if this problem would have occurred under 2.9.4 - certainly, I never encountered it.

I'm on a brand new M1 14" MacBook Pro (2021 model), running Monterey 12.5.1. I downloaded OpenLP on Saturday and was excited to use my shiny new machine at church on Sunday. Not to be. Having created all of my slides and prepared and saved the service, I shut down the computer and thought that my job was done. I remembered an announcement had to be included and so went back to the service. But every image file I attempted to click on threw an error message, one that I've never seen before.

Every image slide? What had I done wrong?

I went through the service and all of the image slide files were in place. The image plugin was active. In fact, all of the plugins, apart from the Planning Centre plugin, were active. However, I deactivated them, one by one, and then reactivated them one by one. No change. I deactivated them all in bulk and reactivated them all in bulk. Still no change.

I then went and relinked (for want of a better word) each image slide file to its location. I ran through the service again, and everything worked. I saved everything, ran through the service, and I was confident that everything worked. I shut down the computer and went to bed.

Sunday morning at church, and the same error stared me in the face. I didn't have time to go through my process of relinking all of the images again, so I got out the trusty old MacBook Pro and loaded everything for Sunday's service onto it. I was glad, once again, that I keep all of my data files - images, videos, whatever else - in the cloud, and that meant that I can access all of the data from any (internet-connected) computer.

And the service then ran pretty smoothly, albeit on version 2.9.4.

So, where did this error come from, and what does it really mean? Is it even related to 2.9.5? Or is it an error of a vanilla flavour?

I know that this problem is going to be due to something that I've done wrong, but what?

Thanks for any help,

Andrew

Comments

Sign In or Register to comment.